It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

German Umlaut not searchable via JSD

Hi,

we are using JSD 3.15.1, JIRA 7.12.1 and Confluence 6.12.0.

We have several project which are in German, but in the JSD portals it is not possible to search for German Umlaute. The system does not find anything. If I replace the Umlaut e.g. with Oe instead of Ö, the pages are directly found.

It does not matter whether the user interface is in German or any other language.

As I have no idea where to look I would really be happy if someone could give me a hint.

 

Many thanks and best regards

Hannah

6 answers

0 votes

Hello Hannah,

Could you please provide us a screenshot of where you are trying to search and the results you are getting?

Trying on my instance, I was not able to reproduce the problem in the default search bar of Help Desk:

Screen Shot 2019-01-08 at 16.32.46.png

Once you provide us the steps to reproduce it, we can report it as a bug on the official Atlassian portal for bug reports.

We will be waiting for your answer.

0 votes

Hi Hannah,

I just checked this out on a matching version of Jira Service Desk and named a few different Request types with a series of the characters "ä", "ö", And "ü"  and doing a search in the portal returned the value's in the search result without issue from the portal view, EXE:

Screen Shot 2019-01-08 at 1.22.04 PM.png

To make sure I am lining up my test with the behavior you are seeing, Is there a specific character or word you are using that is erring, and am I doing the search in the correct location in the screenshot above?

Also, I found another post that is a similar umlaut issue, but occuring in a different location on the jira to Confluence applink, but came back to a character encoding issue on confluence causing the character so render incorrectly, See:

As a next step to rue this out I recommend looking at this KB on Encoding Troubleshooting:

Regards,
Earl

Hi Earl, HI Petterson,

many thanks for your investigation. Our issues occurs in the knowledge database results returned by Confluence. It doesn't matter if we use Ö / Ü or Ä, all of them are not working. Below you can see an example with Ö. It also doesn't matter if the letter is used in the headline or in the body text.

I checked the other topics I found, but they are not fitting my issue as they are talking about another situation.

JSD_GermanUmlaut.png

Hi @Hannah Graebener

Have you been able to solve the issue? If so: how did you do it?

Thanks and liebe Grüße

Martin

We have the same problem with umlauts and JSD -> Confluence search. Using 

-Dfile.encoding=utf-8 -Dsun.jnu.encoding=UTF-8 as suggested doesn't help.

We are also having this problem.

  • Confluence: 6.15.2
  • Jira: 8.1.0
  • Jira Service Desk: 4.1.0

Facing the same issue:
Confluence: 6.15.7
JSD: 4.3.2
JIRA:
8.3.2

No solution, over one yr?

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you