• Community
  • Products
  • Jira
  • Questions
  • For Atlassian Cloud, we are getting error "Could not load FunctionProvider class" when trying to move stories thru workflow (start progress, close, etc)

For Atlassian Cloud, we are getting error "Could not load FunctionProvider class" when trying to move stories thru workflow (start progress, close, etc)

Many users at my company are getting error "Could not load FunctionProvider class" when trying to move stories thru workflow (start progress, close, etc).  This was working last week, but is not working today.

 

 

4 answers

0 votes

Hey Brian,

This is usually related to an uninstalled add-on in JIRA, where its functionalities are still referenced in your workflow (condition, post-function..).

Did you remove any add-on in your JIRA? If so, can you check those steps in your workflow and look for any missed classes there?

Hope it helps! smile

Cheers,
Andre 

Hi Brian,

Please refer to the following link which might be helpful.

https://confluence.atlassian.com/display/JIRAKB/Workflow+action+results+in+Could+not+load+FunctionProvider

 

Regards

Chander Inguva

Looks like this was an upgrade bug in JIRA Cloud and is fixed now?

I am getting this issue today. i don't see anhythig in the post functions. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,088 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you