Fisheye Source tab in JIRA error 401 (unauthorized)

We recently upgraded our JIRA to version 6.0.8 and Fisheye to 3.1.1

I followed the posted Atlassian instructions on integrating Fisheye with JIRA via Application Links and the connection worked fine. I also added the IP and URL patterns per the instructions. No errors during setup or configuration. Everything looks fine.

However, when I get the following error when I try to view Source in a project or via the Source tab in a ticket.

Request to http://fisheye.<mycompany>:8060/failed: Error in remote call to 'fisheye' (http://fisheye.<mycompany>:8060) [AbstractRestCommand{path='/rest-service-fe/search-v1/crossRepositoryQuery', params={query=<project>, expand=changesets[0:20].revisions[0:29],reviews}, methodType=GET}] : Received status code 401 (Unauthorized)

I was able to resolve the issue by enabling anonymous read access to the repository in Fisheye, however, I do not want to do that in my environment for security reasons. Has anyone encountered this issue? I tried following other fixes I saw posted and I've re-created the app link multiple times successfully with different users (who have admin privileges) but no matter which user creates the application link I still cannot view unless I tick the "anonymous read" access box in Fisheye on the repository.

Any help with this would be greatly appreciated. I've also tried setting up permissions groups on the repository with no success. I'm not sure if I'm missing something obvious or there is an issue I'm not aware of.

Thanks.

4 answers

1 accepted

This widget could not be displayed.

Hi Ben,

The user you type while creating the Application Link will be used only to create the Application Link, that's why he needs to be an administrator. It will not be used everytime in order to retrieve information from FishEye.

This error means that the user logged in JIRA side either doesn't exist in FishEye side or is not among the groups allowed to read the repository.

As it works when you enable anonymous access, it's most probable that the JIRA user doesn't exist in FishEye side. Can you please check this?

I hope this helps!

This widget could not be displayed.

Hi Ben,

Yes, it applies to Crowd as well. Can you check if your user is able to login to FishEye from Crowd?

https://confluence.atlassian.com/display/CROWD/Testing+a+User's+Login+to+an+Application

Please note that the user details need to be exactly the same in both JIRA and FishEye, not only the user ID.

This fixed it! Looks like the user account details were out of sync. Once I fixed it and was able to log into Fisheye with the user, the Source tab also began working in JIRA. Coincidentally, user id's of type "built-in" with identical info are also working too.

Thanks much for your help on this one.

This widget could not be displayed.

Hi Felipe,

Thanks for taking the time to get back to me. Does this apply to Crowd authentication as well? We are using Crowd and my user id (the one I'm using in JIRA) is over in Fisheye, and a member of the groups that are allowed to access the repo. Not sure if there is something going on with the Crowd authentication that requires an extra step?

This widget could not be displayed.

I am also having problems with "Received status code 401 (Unauthorized)".  I have JIRA configures to use SSO with Crowd and Crowd is authenticating with LDAP.  I get the unauthorized message even if I enable anonymous access in FishEye.  From FishEye, when I click on "test connection" it says everything is working, but on the JIRA side I cannot access the source.  I'm told by the user who reported this that it used to work, so I probably broke it somwhere along the line when updating JIRA, FishEye or Crowd.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

226 views 3 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you