Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
Level
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Filter gadget behavior

I am having a problem similar to this old post: https://community.atlassian.com/t5/Jira-questions/Dashboard-Gadget-unable-to-add-custom-field-to-Filter-Result/qaq-p/436145

I have two custom field and was able to resolve the issue for one field via the steps proposed in the solution post there.

The other custom field remains problematic.

I have compared context, both global
Both field associated with all the same issues and screens - both have unique associations with some workflow screens

 

One work, one does not - cannot save the filter gadget.

 

Stumped

1 answer

1 accepted

0 votes
Answer accepted
Jack Community Leader Mar 30, 2021

Hi Owen, unsure what might be the cause just yet. Could you please provide more info. To be clear, is this the "Filter Results" gadget you are using? Then you are able to edit the gadget and you find the field but if you add it to the displayed fields you are then unable to save the changes. Is this correct? Can you provide details of the two fields? What is unique about the one field? If you go to the advanced search are you able to add that field as a column in the results of the JQL that is used in the gadget?

Hi Jack,

The problem is with the Confluence 'filter results' gadget behavior.  
For one field, I can add it to the display, save and save the page, getting the expected results.

Adding the other field to the same gadget or a similar gadget prevents saving the filter gadget.
Removing that field again allows saving the gadget w/o the offending field.

Both fields can be added as columns to the query results for the actual JQL filter being used

Jack Community Leader Mar 30, 2021

can you explain "Confluence filter results gadget"? Are you adding filter results w/in a Confluence page here or is this a Jira Dashboard?

It is the Filter Gadget in a confluence page

Jack Community Leader Mar 30, 2021

thanks for the clarification. I wonder if you would get the same results if you attempt in Jira dashboard?

I tried doing this in a Jira Dashboard and the filter Gadget works as expected

Jack Community Leader Mar 30, 2021

I searched a bit in the Community and found this post - Filter-Results-Macro-does-not-work-for-custom-fields that might be worth consuming. It refers to two open issues.

Thank you Jack.  

Jack Community Leader Mar 30, 2021

regarding working in Jira but not Confluence that is sort of what I suspected, though I do not have an answer for you as I have never experienced this. If others that have experienced this specific issue don't chime in I might suggest contacting Atlassian Support directly. If I think of something I will certainly post here. TBH, I suspect this is a known limitation/bug and it would certainly be great to have a solid answer posted here.

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you