Filter does not display results if user not authorized to one of the projects

Hello all!

I have an issue with custom field with type 'label'.

I have created custom field ('Theme') with type 'label' (like 'Epic/Theme') and applied it to several projects.

Then I added a new value for the Theme on one project, and then clicked on it.

I then got the following error:

A value with ID '10001' does not exist for the field 'project'.
 A value with ID '10020' does not exist for the field 'project'.
 A value with ID '10023' does not exist for the field 'project'.

But 'Epic/Theme' used for ALL projects and it working without any errors even if user has no access to the project.

So my question is: why this happen?

How can I fix this?

Many thanks!

1 answer

0 votes

I think we need to see your query really.  The error message you are getting is related to the project field and it sounds like you are trying to search for invalid project IDs

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,075 views 13 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot