Fail to use "ALM Subversion"

I tried to install "ALM Subversion" on one of our test systems, but failed. I tried the following steps:

  1. Install it by Add-on Management
  2. Search for Subverison
  3. Select ALM Subversion and Install.
  4. Go to configure
  5. See only the old configuration of JIRA Subversion.

There are now 2 entries in the configuration of Subversion, and both link to the old configuration page of "JIRA Subversion". Do I have to de-install JIRA Subversion first? What about all the cached data there? And what if ALM Subversion does not work for me anyway? I would like first to understand the situation I currently have.

1 answer

1 accepted

Yes, you need to de-install JIRA Subversion first. Subversion ALM is based upon Atlassian's Subversion plugin, so they share common names witch causes this problem. The documentation does warn about removing the previous Atlassian plugin.

I have gone back and forth between the two versions with minimal issues. The issue I had was with the Atlassian version where it did not remove a service entry. The other issue I have run into was indexing stopped in both plugins.

The Atlassian version broke its configuration to change the timeout period, so I needed to restart Jira manually in order to get the indexing to restart instead of waiting for an hour. I am not sure if indexing would have restarted or not since I never waited, but it was suppose to.

Subversion ALM you just need to reactivate the respository until the indexing process finishes.

Once the full index completed, I had no issues other than the Jira scheduler stopped working, but it was not an issue of either these two products. (It was an UPM issue or memory as best as I can tell.)

Oh, Yes, uninstall both products to get things cleaned up.

Both products have directions about how to do a full index if you want to restart over again. I was a bit confused by Atlassian directions because it was unclear which directories they were talking about.

With Subversion ALM you will need to reconfigure the repository if you uninstall (ie more like a clean install). The Atlassian's plugin is more like a dirty uninstall, so you do not need to reconfigure the respository.

Thank you a lot! Saved my day :-)

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,095 views 13 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot