Error when Linking JIRA and Confluence

I am trying to create a trust relationship between JIRA and Confluence so that I can insert JIRA issues into Confluence documents.

However, in JIRA, when I try to initiate the relationship, I receive the error:

"Unable to auto-configure a Consumer as the remote Consumer-Info count not be found.".

When I attempt to create the relationship from Confluence, I receive this error:

"Unable to auto-configure a Consumer as the remote Consumer-Info could not be found."

What am I doing wrong here?

9 answers

Same problem here! While I have an HTTPS proxy front-end (to serve the content out), the different services (JIRA, Confluence, Stash, Fisheye..) should be able to talk to each other directly on specific ports via HTTP as they all live on the same server. Nevertheless, I get the same exact error when trying to form application links such as JIRA <--> Confluence, or JIRA <--> Stash.

To test, I removed any proxy references from Stash's server.xml, i.e. took out:
secure="true"
scheme="https"
proxyName="xxxxx"
proxyPort="443"
.. then restarted stash, and confirmed from the local system that Stash login screen at http://127.0.0.1:7990/stash (I've added "/stash" as the context path) was accessible with lynx (it worked). Then I logged in to JIRA admin (on the same system), and tried to add Stash with the same URL as an application link.. and got the same error that William describes above.

Here SSL should be out of the picture since it's not used internally between the applications, and proxy should be out of the picture since Stash is accessed directly at Stash's port.

(NOTE: I'm using the latest "standalone" versions of all Atlassian applications on a Large AWS EC2 instance, with Ubuntu Server 12.04.3 LTS, and Java runtime version 1.7.0_45)

2 votes
Renjith Pillai Community Champion Nov 10, 2013

Couple of questions:

  • Are the base urls correctly set in both the instances?
  • Are they reachable from the each of their servers via the configured base url?
  • Are you using the same url while entering the link for the application?
  • Looks like there is a proxy. Can the JIRA server reach the proxy via documents.yeack.com over HTTPS?
  • Are the HTTPS server certificates imported into each others keystore? The logs will indicate what is going on with the connection attempt.

Same problem here. The only thing i did was upgrade HW from solaris to RHEL, and then did a minor upgrade to the Atlassian sw, and all my app links broke.

Confluence 5.3.4

Jira 6.1.4

Both get the above red error.

I had to put in -Dhttp entries in the setenv.sh hooks for Jira and Confluence, in order for the Marketplace web hooks to load via our proxy.

I suspect that the -Dhttp.nonProxyHosts=localhost

either

a) wasn't working proper or

b) needs extra patterns for machine name and machien dns like:

-Dhttp.nonProxyHosts=\"localhost|csa.company.corp|companyMachineName.company.corp\"

but i'm not able to confirm until after hours, when i can do an Atlassian application boucne to make the new env values take place.

Will re-test ApplicationLink setup after that.

Where did all of the comments go from before?? I will haven't solved this issue!

Hi,

This is possibly a solution to this problem, at least in my instance... Mine would not link when the base url of each instance was anything but the local hostname with the non-ssl port. So, change both sides to the non ssl url, since the base url is retreived when the link is being established. I'm not sure why they let you put in a URL, then connect to it, just to then pull the 'base url' from the remote instance and not let you modify it. So, I changed both 'base url' strings to the non-ssl url, linked the apps, then changed them back to the ssl urls they had. The two applications will continue to communicate (once set up properly) on the non-ssl ports, even once you've changed the base url back to what it should be.

I tried that - it sort of worked but I would still get some errors when adding new issues in confluence. Have you gotten it to work without any errors? What type of reverse proxy are you using?

I have gotten it to work without errors, by adding the -Dhttp.nonProxyHosts pattern with localhost, machinenames (fully qualified and short) and dns names (fully qualifid and short).

then all atlassian products basically auto-binded eachother in the ApplicationLinks area (the UI for this has come a LONG way in recent versions. i was impressed). it auto-knew what app was on each port, and i just clicked 'ok' and its been working ever since.

I'm not quite sure I follow - are you talking about adding that as a URL pattern when creating the Application Link or is that a line that you added to the JIRA/Confluence config file?

edit each apps setenv.sh
i edited the entry i had

-Dhttp.nonProxyHosts=localhost

to be

-Dhttp.nonProxyHosts=\"localhost|csa.company.corp|companyMachineName.company.corp\"

and then the bounce each app.

Now in Application Link UI for each app, my URLS no longer caused the errors.

Hello Rob, I have the same issue as described above and I try to use your sollution. However without positive result which gives me the idea that I do something wrong or I miss something (or both).

I modified JVM_SUPPORT_RECOMMENDED_ARGS in jira/bin/setenv.sh to be:

"-Dhttp.nonProxyHosts=\"localhost|atlas.embed-it.nl|confluence.embed.it.nl\""

Then I added, since it is not originally there, JVM_SUPPORT_RECOMMENDED_ARGS in confluence/bin/setenv.sh to be:

"-Dhttp.nonProxyHosts=\"localhost|atlas.embed-it.nl|jira.embed.it.nl\""

atlas.embed-it.nl = my sever running jira and confluence
jira.embed-it.nl =virtualhost on atlas.
confluence.embed-it.nl =virtualhost on atlas.

I restarted both jira and confluence and try to add the link from confluence, but when I add the application https://jira.embed-it.nlit asks me to configure the application URL and after continue I have to manually add the link. So no auto linking. The link is created when I try the solution provided by Evan Jensen but that leads to other problems as well.

Can you help me out Rob.

Thanks for you help,

Frank

i'd have to ask the network team about details of the proxy layer. i had to set up *both* applications (Jira and Confluence) with the new setenv.sh -Dhttp hooks above to make this work though

Hi

I solved this problem by entering JIRA Safe Mode, connect JIRA with Bitbucket and exit safe mode. If some one from Atlassian see this comment, it's better to share this workaround on KB. smile

My original question was about connecting JIRA and Confluence.

Are you saying that connecting JIRA to Bitbucket in safe mode will help fix the JIRA <-> Confluence connection?  Or are you trying to suggest that we should enter safe mode and then connect JIRA and Confluence?

I had same error when connecting JIRA to Bitbucket server and Bamboo. I didn't have any user-installed plugins on Bamboo and Bitbucket. So I think it related to some JIRA plugins. Try it on a test server. Enter Safemode on JIRA and then reconnect it to confluence. It just took 5 minute.

Do we have solution for this  topic ?

Not a good one that works in all scenarios.  I have only ever gotten my linking to work partially (Among other quirks, my confluence can link issues from JIRA but JIRA cannot find Confluence pages).  If you are using HTTPS (as I am) I would look there for the solution - making sure that each server is setup to trust the certificate from the other (even if you are using the same certificate on both) that has been where I have found most progress.

Try my solution. It works for me.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,891 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot