Error trying to add parameter to SIL Post-function

When attempting to add parameters to a SIL Post-function, I'm getting the attached error. This is a new install of JJUPIN. Any idea what could be wrong? Let me know if I need to upload any other information. Thanks!

(Error adding parameter to post-function.txt)

3 answers

1 accepted

Hi Steve,

I noticed you are running katl-commons 2.6.1 on JIRA 5.0. Please note that the 2.6.x versions are for JIRA 6 only. Please use the latest katl-commons 2.5.x. While the versioning might be a bit confusing, 2.5.x and 2.6.x have the same features, but work for different JIRA versions. All other plugin versions look ok to me.

 
 

Thanks for the reply!

Before I realized the correct version I should install, I installed 2.6. I had since uninstalled and installed 2.5 but I guess commons wasn't uninstalled. I uninstalled jjupin and katl-commons, then re-installed 2.5.6. I thought this installed katl-commons automatically but it didn't. I searched the marketplace and installed 2.5.9 of katl-commons. After all of that, I was able to enable katl-commons and JJUPIN. I am still getting an error at the exact same point. Attached are the details of the error. (Error adding parameter to post-function -2nd.txt).

Thanks again!

Also, when I search the marketplace it is unable to find JJUPIN at all, but it can find katl-commons. I'm not sure if that's an indication that Jira thinks there is no compatible JJUPIN version, is that possible? It says I have 5.0 installed.

This time I believe the exception has nothing to do with JJupin. As you can see, the exception happens before entering into our plugin .... Please ensure you installed the correct versions (katl-commons 2.5.9 and JJupin 2.5.6) , restart JIRA and check if the error persists (clear the plugin cache before restart).

Clear plugin cache: Stop JIRA. Go to JIRA Home folder -> 'plugins' directory. Delete the '.osgi-plugins' and the '.bundled-plugins' folders (entirely).

If the problem is still there, we would appreciate some more info (report an issue on http://bugs.kepler-rominfo.com/ )

I went to check the version and it said I had katl-commons 2.6.1 again, so I uninstalled and installed 2.5.9 again. After that, it again said I had 2.6.1 installed. At this point I uninstalled once more, stopped the Jira service, cleared the plugin cache, started Jira, went to the plugin page it it still listed katl-commons 2.6.1 as installed but disabled. I uninstalled again and this time it disappeared from the plugin page. After that I reinstalled 2.5.9. I refreshed the plugin page and it showed 2.5.9. I then tried to add a parameter to a post function and it works! Thanks for the help!

Glad it is solved. Enjoy...

Hi Steve,

Uninstalling JJUPIN will not uninstall its dependencies (katl-commons) and installing the 2.5 version over 2.6 will have no effect since JIRA thinks it's newer and skips the install. If, however, this happened when uninstalling katl-commons, then it's definitely a caching problem.

Anyway, glad it's solved now.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

133 views 0 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you