Error restoring data from 4.x into 6.x

I have installed 6.x and after restoring the system from my old 4.x I get null pointer errors. I am new to JIRA. How do I start to locate my error? Th einstall is fine. Errors happen immediatly the restore process ends. I cannot access the 6.x install at all afterwards.

4 answers

This widget could not be displayed.

Hi, go through the upgrade notes for JIRA 6. You need to first upgrade to the stated versions in between, e.g. JIRA 5 etc before you can get to 6. You can't get to 6 in 1 go.

This widget could not be displayed.

I have found some supporting software that needs to be upgraded, MySQL upgrade needs Window WIC and .NET for example. Ill close this for now until I have all things up to date.

This widget could not be displayed.

Hello Greg,

After upgrading the other software tool that you have such as MySQL, etc.. Please note that if you are planning to upgrade your JIRA instance from a version prior to 4.4.5 into JIRA 6.0, then you need to upgrade your JIRA instance into 4.4.5 first, before upgrading it to the latest JIRA version.

I hope that helps.

This widget could not be displayed.

Ok, I have upgraded from 3.x to version "4.4 build 649" and everything works fine. Next i updated MySQL, Java etc and all is still ok.

However, any upgrade past this 5.x, 6.x fails and the browser is displaying a Null pointer exeption error.

I have no custom plugins but I get an error in the log;

2013-06-20 15:28:15,280 localhost-startStop-1 INFO [atlassian.plugin.manager.DefaultPluginManager] Initialising the plugin system

2013-06-20 15:28:16,827 localhost-startStop-1 ERROR [atlassian.event.internal.AsynchronousAbleEventDispatcher] There was an exception thrown trying to dispatch event 'com.atlassian.plugin.event.events.PluginFrameworkStartingEvent@16d36a5' from the invoker 'SingleParameterMethodListenerInvoker{method=public void com.atlassian.plugin.osgi.container.felix.FelixOsgiContainerManager.onStart(com.atlassian.plugin.event.events.PluginFrameworkStartingEvent), listener=com.atlassian.jira.plugin.JiraOsgiContainerManager@1ba994b}'

and this appears to be where the failure starts.

Any help is much appreciated.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you