Error rendering 'databaseinput'. Please contact your JIRA administrators.

We are not sure where to look next.  We are getting the following error on the Kepler Database Custom Field Plugin:  Error rendering 'databaseinput'. Please contact your JIRA administrators.

 

Here are the details:

  1. The custom fields were working prior to the upgrade to JIRA 7.0.  We upgraded from 6.4.10.
  2. We are obviously running the Server version of JIRA.
  3. If we remove the connection info from the context.xml in the conf folder, the field will actual render but will only have None in the drop down.
  4. Here is the info from the context.xml file.  I have removed the password and IPs.
    1. <?xml version='1.0' encoding='utf-8'?>
      <Context>                                  -->
          <WatchedResource>WEB-INF/web.xml</WatchedResource>
          <WatchedResource>${catalina.base}/conf/web.xml</WatchedResource>
      <Resource name="JIRACustomTables"
            auth="Container" type="javax.sql.DataSource"
            username="username"
            password="password"
            driverClassName="net.sourceforge.jtds.jdbc.Driver"
            url="jdbc:jtds:sqlserver://1.1.1.1:1433/JIRACustomTables" />
      </Context>
  5. If we change the username or password to be incorrect in the Context file then the field will also render and show only None in the dropdown.
  6. We have updated all plugins and are not getting any as action required.
  7. We have tested the Query and it works directly against the DB.
  8. We do not see any errors in the logs we have looked at.  With the exception of getting an error when we put the incorrect password or user name.  We are looking in the ..\ProgramFiles\Atlassian\Jira\Logs and ..\Atlassian\Application Data\JIRA\log folders.  We are not sure if there is some other place we should be looking to capture the plugin error.
  9. We tried uninstalling and reinstalling the plug-in.
  10. We tried adding a new field and it has the same results.
  11. We have restarted JIRA several times.
  12. We have verified that the ..\JIRA\lib folder contains: jtds-1.3.1.jar

 

We are really at a loss as to what to check next.  We are looking for guidance on next steps.

5 answers

1 accepted

Hi Eric,

 

You will need to upgrade the jdbc driver, the Microsoft JDBC Drivers 4.2 for SQL Server should resolve your problem.

 

Best regards,

Alex

I spent hours researching this. The clue was in @Alexandru Geageac comment to upgrade to MS JDBC drivers. Since JIRA 7 uses Tomcat 8 I kept failing because the wrong jar was being loaded. so for Tomcat 8 JIRA 7 download and copy Microsoft's "sqljdbc4.jar" file into the JIRA \lib directory.

Then change your JIRA conf\context.xml connection as follows, substituting for your own CONNECTION_NAME, USERNAME, PASSWORD, SERVER, PORT, and DATABASE_NAME. Be sure to use the semi-colons in the url string:

<Resource name="CONNECTION_NAME"
        auth="Container"
        type="javax.sql.DataSource"
        username="USERNAME"
        password="PASSWORD"
        driverClassName="com.microsoft.sqlserver.jdbc.SQLServerDriver"
        url="jdbc:sqlserver://SERVER:PORT;DatabaseName=DATABASE_NAME"/>

 

 

Did this require a restart for the changes to take place?

Yup, you should restart the JIRA instance...

Dan thank you for pointing to the right direction, I had to use sqljdbc42.jar instead for JIRA 7.1.7

Can you tell me where you found this file?  Every time I try to download it from MSFT, I get directed the 4 version instead.

Fantastic resolution Dan.

 

Thanks a lot!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,006 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot