Error on JIRA source tab for disabled Fisheye repositories

For JIRA projects that do not have repository linked to, we are seeing the following errors on the source tab. Issues in projects that have Fisheye linkage work well as the Perforce changelists are appearing correctly on the source tab. The repositories in the errors are currently disabled. Why are we seeing these errors for disabled repositories? What can I do to fix this without deleting the currently disabled repositories in Fisheye.

This list of changesets may be incomplete, as errors occurred retrieving changesets from the following repositories:

Repository Autolab_test on http://abc123.corp.net/ failed: Error in remote call to 'abc123' AbstractRestCommand{path='api/rest/query', params={query=select revisions from dir / where comment matches 'XXX-7' order by date group by changeset return csid, rep=Autolab_test}, methodType=POST} : unknown repository: Autolab_test

Repository TestSVN on http://abc123.corp.net/ failed: Error in remote call to 'abc123' AbstractRestCommand{path='api/rest/query', params={query=select revisions from dir / where comment matches 'XXX-7' order by date group by changeset return csid, rep=TestSVN}, methodType=POST} : repository not in correct state: Repository is stopped

Repository Autolab on http://abc123.corp.net/ failed: Error in remote call to 'abc123' AbstractRestCommand{path='api/rest/query', params={query=select revisions from dir / where comment matches 'XXX-7' order by date group by changeset return csid, rep=Autolab}, methodType=POST} : repository not in correct state: Repository is stopped

6 answers

Atlassian support answered my question. Turns out there's an option to disable unmapped project. Per Fisheye plugin configuration tutorial:

Since version 2.5, the FishEye plugin has provided a "Disable for unmapped JIRA Projects" option in the FishEye Configuration administration screen. If set to true, the FishEye tab panel will not display for projects that do not have explicit repository mappings.

Go to <tt>Administration > Fisheye plugin > Configure</tt> and set the "Disable for unmapped..." to <tt>true</tt> or <tt>ON</tt>, that should fix the issue.

"Disable for unmapped JIRA Projects" is no longer an option in the current versions of the tools and plug-in (v5.2.5 plug-in). And, we are seeing this issue for any repository that meets one of the following conditions:

  • has a legitimate error condition in fisheye
  • is "stopped" in fisheye
  • is "disabled" in fisheye

This is a problem for any JIRA project that does not have explicit project links defined between it and Fisheye repository(ies).

Our only solution was to remove the stopped and disabled repositories.

My use the word "current" was mis-guided. Newer versions of both Fisheye (2.10.2) and the Fisheye plug-in (5.2.9) resolve this issue.

Did you figure this out?

I have the same problem. Anyone any idea how to fix this?
 
Using Jira 5.0.2 with the latest Fisheye plugin version.

I have the same problem. Anyone any ideas how to fix it?

I believe you need to remove your project link between repository and the project. If you disable the repository then Jira needs to be disconnected as well.

http://confluence.atlassian.com/display/JIRA/Deleting+a+Project+Link

Read about adding a project link to understand why better.

http://confluence.atlassian.com/display/JIRA/Adding+Project+Links+between+Applications

We have the same issue, but not only the stopped or disabled repositories are listed, but all not accessible (Received status code 403 (Forbidden). So removing the application link is not an option.

We have Jira v4.4.5

It is quite confusing, as non of reported repositories are relevant for the current project (they are not mapped)

Atlassian support answered my questions. Turns out there's an option to disable unmapped project. Per Fisheye plugin configuration tutorial:

Since version 2.5, the FishEye plugin has provided a "Disable for unmapped JIRA Projects" option in the FishEye Configuration administration screen. If set to true, the FishEye tab panel will not display for projects that do not have explicit repository mappings.

Go to <tt>Administration > Fisheye plugin > Configure</tt> and set the "Disable for unmapped..." to <tt>true</tt> or <tt>ON</tt>, that should fix the issue.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

94 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you