Error importing data while migrating Jira

Coming from JIRA v4.1.2, and trying to migrate to JIRA 5.0.6.

Went through the migration steps, I think correctly. On first attempt to migrate got the following error message :

"(SQL Exception while executing the following:INSERT INTO jiraaction (ID, issueid, AUTHOR, actiontype, actionlevel, rolelevel, actionbody, CREATED, UPDATEAUTHOR, UPDATED, actionnum) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) (Incorrect string value: '\xEF\x83\xA"

This is quite similar to this report : https://answers.atlassian.com/questions/55520/error-importing-data-while-migrating-jira-incorrect-string-value

So dropped&recreated the database, unzipped the xml backup and uploaded it to the server (debian).

Issued sed -i 's/^C//g' backup.xml - there was no output (no error, no summary not success confiramtion), have no clue if that's good or bad...

And tried the migration again. This time again the same error message. Could anyone give some help/hint?

9 answers

This widget could not be displayed.
Did you already check this: https://jira.atlassian.com/browse/JRA-21224?focusedCommentId=198940&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel ?

what is your MySQL version and the encoding of your table jiraaction? Please post the result of

select charset('jiraaction')

This widget could not be displayed.

Hi Dieter, thanks for your comment.

Server version: 5.1.61-0+squeeze1 (Debian)

mysql> select charset('jiraaction'); +-----------------------+
| charset('jiraaction') |
+-----------------------+
| latin1 |
+-----------------------+
1 row in set (0.00 sec)
Missed the article, thanks. But :
root@jira:~# mysql jiradb -e "show variables like 'char%'" -p
Enter password:
+--------------------------+----------------------------+
| Variable_name | Value |
+--------------------------+----------------------------+
| character_set_client | latin1 |
| character_set_connection | latin1 |
| character_set_database | utf8 |
| character_set_filesystem | binary |
| character_set_results | latin1 |
| character_set_server | latin1 |
| character_set_system | utf8 |
| character_sets_dir | /usr/share/mysql/charsets/ |
+--------------------------+----------------------------+
This seems ok, and indeed I did create the db with "CREATEDATABASEjiradb CHARACTERSETutf8;"...
Or am I wrong?
This widget could not be displayed.
I think your database was created correctly but the table jiraaction seems to have the wrong character set. It should be utf-8 not latin 1 which afaik only stores 8bit characters. Will check this with a working installation tomorrow ..
This widget could not be displayed.
Can you add the output of show table statu ? This should give the character set of each table
This widget could not be displayed.

http://pastie.org/4123084

Hope meant like this. :)

This widget could not be displayed.

Just checked, the command select charset('jiraaction'); seems not returning useful data...

mysql> select charset('jiraaction');

+-----------------------+

| charset('jiraaction') |

+-----------------------+

| latin1 |

+-----------------------+

1 row in set (0.00 sec)

It returns the same result even for a non-existent table as well...
mysql> select charset('foo-not exists');
+---------------------------+
| charset('foo-not exists') |
+---------------------------+
| latin1 |
+---------------------------+
1 row in set (0.00 sec)

This widget could not be displayed.

Magic...Just reattempted the migration and seems it worked fine. But as far as I remember I have not done anything differently...

I'll ask one of the users to verify if everything is migrated. If that get's verified I'll perform an addtional test migartion to see if I could reproduce the same result. Let's hope the best.

This widget could not be displayed.

Great...clean debian install, clean mysql-server install, clean installation of jira.

on migration : "Unable to find ActiveObjects plugin. The plugin must be enabled for the restore to work."

https://answers.atlassian.com/questions/54714/jira-5-migration-error-unable-to-find-activeobjects-plugin

This is getting more and more wierd...

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

54 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you