Error doing an xml-import to a test environment

I am setting up a test environment for my JIRA and have created an XML backup of my production environment.

During the restore process on the test server I get an error message:

Error importing data: java.lang.IllegalArgumentException: [GenericDelegator.makeValue] could not find entity for entityName: KPlugins

It has soemthing todo with the installed plugins on my production site, I guess. I have tried to find any solutions but failed so far! Any suggestions?

The version is 5.0 and the test environment is a clean installation on CentOS with Postgres 8.4.13 as db. My production environment is Debian with postgres 8.3.12. Could the differences in the platform be an issue, perhaps?

2 answers

1 accepted

Hi Svante,

Is it possible that you have either the Minyaa or Kaamelot plugins installed in your production instance? The reason I ask is because I was searching your error message and I came across an error suspiciously like yours that is releated to an issue with restoring XML data from an instance that has the Minyaa/Kaamelot plugins installed: http://www.minyaa.com/jira/browse/MYAA-850

That specific bug report has been closed as obsolete, and it refers to a much earlier version of JIRA, but it does seem that if you have those plugins installed then you still need to follow a different procedure to import your data as described in this document: http://www.minyaa.com/documentation/latest/Installation/minyaa.installation.with.existing.data.html

If this issue isn't Minyaa/Kaamelot related then please open a ticket with Support and we will investigate this issue for you further.

All the best,
John

Hi John,

Thanks for your clue! It was a problematic plugin, the User Group Picker (https://marketplace.atlassian.com/plugins/com.keplerrominfo.jira.plugins.usergrouppicker)

I re-started and began with installing that plugin in the test environment and then the XML restore went fine! Do you think this needs to be escalated to support?

rgrds,

// Svante

I'm glad to hear that you managed to find the cause of this issue Svante, and I would recommend that you raise it with the plugin developer but it seems this one isn't from Atlassian so you will need to inform the people found here about this problem: https://marketplace.atlassian.com/plugins/com.keplerrominfo.jira.plugins.usergrouppicker/version/32/support

All the best,
John

0 vote
Tim Evans Atlassian Team Oct 07, 2015

Atlassian Support has a KB article that may help customers when this issue is encountered:

https://confluence.atlassian.com/display/JIRAKB/Could+not+find+entity+for+entityName+-+when+restoring+a+XML+backup+into+a+JIRA+application

Cheers!

Tim | Atlassian

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

174 views 1 17
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you