Empty Backlog Even Though Issue Exist

After migrating GreenHopper from version 6.1.2 to 6.1.3.1, the backlog issues disappeared of the agile board.

All of the issues with status open and reopened doesn't appeared on agile board.

On agile board, the number of issues are shown in Tools > Configure > Columns

I upgraded the GreenHopper from version 6.1.3.1 to 6.1.3.2 to try solve this problem, but doesn't worked.

I tried solve this problem following resolution sugest in this post (https://confluence.atlassian.com/display/GHKB/Empty Backlog Even Though Issue Exist), but also doesn't worked.

Error messages on jira's log:

atlassian-jira.log.1:2013-02-21 17:09:51,249 http-bio-8443-exec-5370 INFO wual 1029x1228560x7 10q0dig 10.18.121.53 /rest/api/2/issue/AMPN-7351/comment fields.layout.field.AbstractFieldLayoutManager Field layout contains non-orderable field with id 'customfield_10471'.

...

atlassian-jira.log.2:2013-02-21 14:41:56,728 http-bio-8443-exec-5113 WARN epaj 881x1185157x2 1i2r538 10.18.125.1 /issues/ jira.issue.managers.DefaultCustomFieldManager Warning: returning 1 of 2 custom fields named 'Sprint'

........

atlassian-jira.log.1:2013-02-21 17:09:50,886 http-bio-8443-exec-5370 ERROR wual 1029x1228560x7 10q0dig 10.18.121.53 /rest/api/2/issue/AMPN-7351/comment jira.plugins.common.Utils Gantt-specific customfield with configured name 'customfield_10471' or default name 'Greenhopper Sprint' does not exist!

customfield_10471 is:

ID: 10471

CustomFieldTypeKey: com.pyxis.greenhopper.jira:gh-sprint CustomFieldSearchKey: com.pyxis.greenhopper.jira:gh-sprint-searcher

CFName:Sprint

Description: Sprint field for GreenHopper use only

Default Value: (Null)

FieldType:(null)

Project: (null)

IssueType: (null)

Another attempt to solve the problem was uninstall/install the GreenHopper Plugin, but doesn't work.

I've created the test environment to downgraded GreenHopper Plugin to version 6.1.2, but the problem changed and bencame worse, with the message GreenHopper is currently unavailable. This might be because an upgrade task has failed to run or has not not yet completed. and the agile board doesn't work.

3 answers

Hello

This case the problem was with the Status and how JIRA JQL searches it. due to this problem we have raised two bugs:

And the workaround was to create a new Status "OPEN" and change it on the workflow the re-associate all the projects to this workflow and the Board works again.

0 votes

If you go to Administration > Issues > Fields > Field Configurations, is there any fields hide there, include GreenHopper fields (Sprint, Story Point and Rank)? If so, you just need to click on Show and then re-index your instance.

Hope that helps.

this didnt work for me

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,146 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot