Edit feature of 'Run Macro' only display the first word


I have successfully configured the Bob Swift's Run Macro using the following guide (https://bobswift.atlassian.net/wiki/display/SCRP/Script+-+Editable+Paging+Tables) and I now have a quick question.

When I want to edit a row, all the datas are correctly loaded but my description is only displayin the first word. I tried to play with single and double quotes, same problem.

Is anyone else experiencing the same problem as me ?

4 answers

Sounds like a quoting problem, but it is hard to say without the details. Play around with the quoting some more and then if you are still stuck, open a support issue and attach your wiki markup. Maybe there is something that can be spotted.


Still no luck :(


  , '{run:id=e' , id
  ,   '|buttonPadding=0'
  ,   '|keepRequestParameters=true'
  ,   '|anchor=edit'
  ,   '|titleRun=Edit}'
  ,     '{extract-link:redirect=true}'
  ,       '$page_url'
  ,       '?run_selection=run&run_edit_id=' , id 	
  ,       '&run_edit_name=' , name  
  ,       '&run_edit_project=' , project
  ,       '&run_edit_description=' , description 
  ,       '&run_edit_date=' , date
  ,       '&run_edit_isopen=' , isopen
  ,       '&run_edit_status=' , status
  ,       '&run_edit_highlights=' , highlights
  ,       '&run_edit_pathforward=' , pathforward
  ,       '&run_edit_comments=' , comments
  ,       '&run_selection_hideEdit=false'
  ,       '#$page_anchor_e' , id
  ,     '{extract-link}'
  ,  '{run}'
  , '{table-cell} {table-cell}'
  ,'{run:id=d' , id
  ,   '|buttonPadding=0'
  ,   '|titleRun=Delete}'
  ,     '{sql:dataSource=packagingRDS}'
  ,       'delete from pkgteam.tracking where id = ' , id
  ,     '{sql}'
  ,     '{extract-link:redirect=true}'
  ,       '$page_url?&run_selection=run'
  ,     '{extract-link}'
  ,  '{run}'
  ,'{table-cell}{table-row}{table}') AS "Actions"
  FROM pkgteam.tracking ORDER BY id

and my EDIT function:

update table
      set name = '$name', project='$project', date='$date', description='$description', isopen='$isopen', status='$status', highlights='$highlights', pathforward='$pathforward', comments='$comments'
      where id = $id

I tried to modify this line:

'&run_edit_description=' , description

with 'description', no changes. I also tried to update the SQL update w/o success :(

It is hard to deal with this within the confines of answers, I still suggest you open an issue.

I can't run your sql, so please run the sql to produce a 2 or 3 rows of wiki markup that can be used to view and test with.

Ok, I was confused because you support link was actually re-routing to answers.amazon.com.

I created a support case : CSP-106260 for this issue.


Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

526 views 6 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot