Different version Jira export and import

The version of old jira is 4.0.1,the verison of new jira is 5.0.2。

I export a xml file from 4.0.1 jira ,when I import the xml file to 5.0.2 jira , the report is this:

java.lang.IllegalArgumentException: [GenericDelegator.makeValue] could not find entity for entityName: JWatcher

How to solve this problem? Are there any other ways I export and import in different version jira ?

1 answer

This widget could not be displayed.

Seems your JIRA 4.0.1 has a customization which added a new entity definition (JWatcher). Either remove it before you export or do the same in 5.0.2 before you import.

Thank you very much for Jobin Kuruvilla [Go2Group]

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

79 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you