Deploying a custom plugin in JIRA 5.2

I have upgraded Jira 4.2 to Jira 5.2. I have a set of custom plugins that are not from atlassian. I copied all our plugins into WEB-INF/lib and restarted Jira instance(like i always do with JIRA 4.2). But i dont think these plugins are enabled.

Please tell me if there's a different method to install custom plugins into JIRA 5.2???

Thanks in advance...

1 answer

1 accepted

1 vote

Hi there,

I recommend you to follow the guide below. Besides, do make sure you are using the updated plugins in the new 5.2 instance.

https://confluence.atlassian.com/display/JIRA042/Managing+JIRA%27s+Plugins#ManagingJIRA'sPlugins-ManagingPluginsManually

Regards.

Hi,

I tried the steps in this link. The plugin was developed by us for customised Jira operations. I have put it in WEB-INF/lib in Jira Installation Directory. And i have restarted Jira instance. But i still could not find it in the list of plugins in Jira Administration...:(:(

If it's not on the list there, then it's not loading correctly.

I'm pretty sure that all you've done is taken a plugin for 4.2 and copied it into 5.0. Unless the plugin is immensely simple, then that's almost certainly going to fail miserably because a LOT of stuff has changed since then.

Two things you need to do:

1. Recompile the plugin for 5.x

2. Read your logs - as the plugin is not loading, these will not only confirm the failure to load, they will probably tell you why (which is probably going to me a missing API call or library because you haven't recompiled it)

I'd also strongly recommend

3. Convert the plugin to a type 2, then you won't have to mess around with WEB-INF/lib

Hi,

I tried all these.But no result..:(

How should i deploy non-atlassian plugins into JIRA 5.2. My plugins were built fro the purpose of handling some SOAP service operations in JIRA 4.2. But these are not detected by the JIRA 5.2 system.

Please help me solve this...

Thanks in advance....

To restress what Nic said.
  • Can you please explicitly verify that you compiled it with JIRA 5.2 dependencies?
  • Please check the atlassian logs and post the errors that you observe in that here.

It is tough to help you without getting the right information.

Indeed, if you have recompiled, and are now trying with the new versions, then we are completely stuck. You need to look in the logs, read the erors, see if they make any sense to you, and then tell us what they are if they aren't helping you.

My usual example - imagine you are a car mechanic. Someone rings you up and says "my car won't start", and nothing else. You really can't help them until you know if the car is trying to start and just churning (out of petrol), no lights come on (flat battery), bent out of shape (savaged by a horde of rampaging penguins), etc...

Even for 4.4, ll the above points apply. Your error indicates you haven't compiled the plugins for 4.4?

Sorry...I had to drop the idea of direct upgrade to JIRA 5.2. I am asked to upgrade to JIRA 4.4 and then to JIRA 5.2. I did upgrade JIRA 4.2 to JIRA 4.4.

But still, I find that the functions Create Issue and Clone Issue are not working. But all other functions are working fine.

I studied the logs and found that, the custom plugin that controls the create issue operation, requires a few methods available in the plugin atlassian-jira-4.2.jar.

But im not able to deploy this jar into WEB-INF/lib...:(:(

This is the error that i get while Creating an issue in JIRA 4.4

HTTP Status 404 - Could not execute action [CreateIssueDetails]:com.atlassian.jira.config.properties.ApplicationPropertiesImpl: method <init>()V not found<p><small><small><pre>java.lang.NoSuchMethodError:

Please tell me how to solve this...:(:(

Yup, seems there is a method signature change in the new version of JIRA (indicated by the error).

Hi Jobin,

Actually, those plugins were developed by a different vendor and we use it in the form of a jar, put inside WEB-INF/lib in JIRA 4.2. There are 5 of it. 4 are working fine. Only 1, which is responsible for create issue and clone issue creates a problem. Should i recompile it and deploy???

Ok...then i will modify the code, compile it again and re-deploy...and then check if its working fine..

Thanks...

I am modifying my custom plugin to suite JIRA 4.4. I changed the jira.product.version in pomxml to 4.4. When i compiled the cde in eclipse, it showed a few errors.

The type com.atlassian.crowd.embedded.api.User cannot be resolved.

I dont find a jar for this class in maven repository. Can you please tell me where to find it???

Thanks i advance...

I think you may need to change the dependencies in your pom.xml as well as the version (there's a big change in user handling between 4.2 and 4.3 and I think you've run into that)

Try having a look at an empy plugin created by atlas-create-jira-plugin in the SDK

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

300 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you