Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,464,836
Community Members
 
Community Events
176
Community Groups

Delet Product

I will like to delete Jira from my Atlassian account. There is no option available to delete /remove a product from my account, the only option available is to delete my entire Atlassian account. Please help me out with this, I have been on this issue for 2 years now.

Thanks

2 answers

1 accepted

4 votes
Answer accepted

Hi @Femi Adigun 

You'll need to be an Organization Admin to do this - then follow these instructions:

  1. Go to https://admin.atlassian.com/
  2. Select your organization
  3. From the navigation menu, select Billing
  4. Select Manage Subscription next to the appropriate product
  5. In the box which Jira is in, select the 3-dots icon (bottom-right corner)
  6. Select Delete, then follow the instructions

Please note that all data will be deleted immediately during this process.

See more details on this help page

Ste

"Please note that all data will be deleted immediately during this process." - when I tried this delete, it told me the product would stick around for 4 weeks. The site & data are still there - which is a not what I was expecting as I want to do another trial migration - now I have to wait 4 weeks?

Hi @Andrew Clements 

I tested this again and still works as per my previous answer for me, with the same "delete" message.

Can you clarify what steps you took to delete your product?

Ste

I go to Billing, Manage Subscriptions, Delete. I get this:

cancel-jira.PNG

"Delete" changes to "Cancel". There is no way around it. You are stuck with it. You also can't delete the organisation because you can't delete the product. I created another organisation and was able to add and delete Jira from that, so it's just a bit inconsistent.

Hi @Andrew Clements 

Have you tried cancelling your subscription first, then deleting the site after?

Ste

The cancel option remains there - ie: no delete option appears (tried cancelling a few times). If I can figure out how to delete the organisation, I'll do that.

Deleted user Nov 01, 2022

Hi, I'm having the exact same problem. I'm trying to delete an organisation, but can't do it because of this error: "Your organisation has products that you need to remove before deleting it." The thing is that I can not delete the product, because the only option is to "Cancel" it (which I did). There is no way to delete it immediately, therefore there is no way to delete an organisation.

Suggest an answer

Log in or Sign up to answer