Dashboard widgets sometimes stay emtpy on jira 6

Hi,

I've installed jira 6 and imported data from jira 5.
Everything work perfectly but not the dashboard.

The dashboard isn't displaying correctly the widgets. Most of the time, they stay empty and activity stream display "An error occurred while trying to retrieve recent activity.".

Sometimes, some of them are displayed:


I have checked the logs and I doesn't see any errors when refreshing the page.
I have tried to disable every plugin, disable some widgets but it doesn't change anything.

It is a WAR installation on linux with ssl + proxy. Proxy +ssl are configured in sever.xml.

I have searched for hours, but i haven't seen similar problems

Thanks for your help!

5 answers

This widget could not be displayed.

Hi Dorian,

Welcome to Answers!

The problem with gadgets not loading properly is something you can debug from within your browser, eg by using the Chrome Web Inspector. Can you verify you don't have any errors in the console in your browser?

Also, to be sure, did you set the proxyName, proxyPort and scheme attribute on the connector in your server.xml file?

Cheers,

Tom

Thank's for your answer!


Yes I have set the proxyName, proxyPort and scheme in server.xml.

With some web consoles (like de Firefox or Chrome ones) I see 403 on some files.
But when I clic on these links, I have any 403 and I can see files which should be widgets data (xml and json content).
I have no JS errors, juste some warnings.

If I understand right, these xml and json are parsed by some JS, so it is client-side. And I don't understand how files permissions can change if I'm still connected on jira. Moreover I have the same problem with public dashboard.

This widget could not be displayed.

Hi Dorian,

Can you also double-check that the base url for JIRA is set correctly, with https included?
Do you also have problems connecting to the Atlassian Marketplace?

Kind regards,

Tom

Hi,

I have checked again my base URL and the "https" is included.

A few day ago I have encountered some troubles with the Marketplace but it was before I set correctly the proxy attribute in server.xml. Now it works perfectly.

Cheers

This widget could not be displayed.

I have the same issue, it looks like since Jira 6 the dash board is all messed up. Im using IE 8 and i have disabled view intranet sites in compatibility mode.

This widget could not be displayed.

Was a solution found for this?  I have the same issue.  Sometimes a couple of widgets will load, sometimes not, it seems quite random.

This widget could not be displayed.

It was an issue with our load balancer and our two proxy. If the main page was loaded trough proxy #1 and the request for widgets trough proxy #2 a 403 was returned.

In my case it was a session, token or ip-forwarding issue.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

112 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you