It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

DB Error on upgrading JIRA from 7.13.5 to 7.13.6 (and above)

Hello Dear community

 

I'm currently facing a strange behavior with our JIRA Software system

I tried to upgrade it from 7.13.1 to 7.13.6 and i was facing  a problem with our DB connection (an Oracle one)

I tried (with exactly the same method based on a custom RPM package) to upgrade from 7.13.1 to 7.13.5, it worked perfectly.

 

Now i'm trying the 7.13.5 to 7.13.8 upgrade, and i'm facing the DB problem again..

 

Has someone any clue on how to go further ? I've seen nothing in the release notes related to Oracle or DB betwee, 7.13.5 and 7.13.6

 

Best regards

---

2019-09-19 15:57:41,936 JIRA-Bootstrap INFO      [c.a.jira.startup.JiraStartupLogger]

    Database configuration OK

    ___ Database Configuration _________________

         Loading entityengine.xml from                 : file:/opt/atlassian-jira/atlassian-jira/WEB-INF/classes/entityengine.xml

         Entity model field type name                  : oracle10g

         Entity model schema name                      :

         Database Version                              : Oracle - Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production

                                                         With the Automatic Storage Management option

         Database Driver                               : Oracle JDBC driver - 12.1.0.2.0

         Database URL                                  : jdbc:oracle:thin:@//[...]:1521/[...]

         Database JDBC config                          : oracle10g jdbc:oracle:thin:@//[...]:1521/[...]

2019-09-19 15:57:41,996 JIRA-Bootstrap INFO      [c.a.jira.startup.JiraStartupLogger]

    ___ Starting the JIRA Plugin System _________________

    

[...]

java.lang.NoSuchMethodError: com.atlassian.jira.database.DatabaseVendor.getVersion(Ljava/lang/String;)Ljava/lang/String; at com.atlassian.jira.health.checks.database.SupportedDatabaseVersionHealthCheck.isSupported(SupportedDatabaseVersionHealthCheck.java:63) at com.atlassian.jira.health.checks.database.SupportedDatabaseVersionHealthCheck.getHealthCheckResults(SupportedDatabaseVersionHealthCheck.java:94) at com.atlassian.jira.health.checks.database.SupportedDatabaseVersionHealthCheck.doPerform(SupportedDatabaseVersionHealthCheck.java:80) at com.atlassian.jira.health.HealthCheckTemplate.perform(HealthCheckTemplate.java:23) at com.atlassian.jira.health.DefaultHealthCheckExecutor.runCheck(DefaultHealthCheckExecutor.java:74) at com.atlassian.jira.health.DefaultHealthCheckExecutor.lambda$applyAndCollectExceptio[...]

2 answers

1 accepted

1 vote
Answer accepted

I think this error is not related with your database or database driver. Two .jar files are not compatible with each other. The .jar file containing "com.atlassian.jira.health.checks.database.SupportedDatabaseVersionHealthCheck" class is not compatible with the .jar file containing "com.atlassian.jira.database.DatabaseVendor".  But I don't know which jar file they are.

i  needed some time.. but the following shell found to jar containing the same classes

for jarfile in $(find . -name "*.jar" ); do     if (jar tf $jarfile| grep com.atlassian.jira.database); then  echo "*** $jarfile ***"; fi; done

 

./WEB-INF/lib/jira-api-7.13.1.jar

./WEB-INF/lib/jira-api-7.13.8.jar

 

Removing the older one do the job... thanks for the help..

I will look into my install script to be find why i have these two

Thanks for the script. If you accept this solution or add your script as a new solution and accept it, people with similar problems may easily find the solution.

0 votes

What is your RPM package doing differently to a supported upgrade method?

I should have miss something... which supported upgrade method ? i have only a tar.gz (?!)

Your question explicitly said you were using a custom rpm, which is not a supported upgrade method.

What are you actually doing to upgrade here?

i've understood... i was just saying "i'm not aware that there is an existing supported upgrade method"

Basically the rpm install the tar.gz content preserving the modified configuration files, and copy the oracle jdbc compatible with our oracle db. it's based on https://github.com/minfrin/atlassian-rpms/tree/master/jira

If you have a proper and nicer way to upgrade a running jira instance... i would be happy to use it

See https://confluence.atlassian.com/adminjiraserver/upgrading-jira-applications-938846936.html for a supported method.

The problem with binding these into RPMs is that they might not be suitable for your particular install.  Your snippet of log also seems to point to something that the RPM seems to have missed, or preserved when it should not have.  So I've learned not to trust them much. 

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

864 views 6 24
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you