Custom event missing from post function dropdown

I am trying to fire a custom event from a workflow but the event I created isn't in the dropdown on the post function screen. Here's what I did:

  1. added a new event called "Issue Ready for QA" 
  2. added a notification to the project's scheme to use the new event
  3. created a draft workflow
  4. selected the transition
  5. opened the post function tab
  6. opened the existing "Fire a Generic Event event" post function for editing

Here's the problem, the event I created in step 1 isn't in the droopdown. I've tried discarding my draft and opening from text and diagram view but it's just not there. What am I missing? 

Thx! 

2 answers

1 accepted

It turned out to be a resolution issue. On my laptop, I couldn't see the full list or access it using the arrow keys. On a whim, I checked on a monitor and it was at the bottom of the dropdown. 

This helps! I faced the same and was wondering what happened!

0 vote
Maarten Cautreels Community Champion Jul 05, 2017

Hi Kathy,

I just gave it a try on our JIRA (Server v7.3.4) and the custom event was simply available as an option. I've tried multiple templates for the event but that didn't change anything.

The documentation (Adding a custom event) does not mention anything about certain events not being available in a post function so I have no idea why it does not appear in your case.

So I would suggest getting in touch with Atlassian Support. Please do come back to us if they gave you the answer as this might help other users in the future as well. :-)

Best,

Maarten

Thanks, I'm on cloud so that might be different. I was hoping I was just forgetting a step since it's been a little while since I did this but I will put in a support request. 

Maarten Cautreels Community Champion Jul 05, 2017

I just gave it a try on my Cloud Test Instance and I don't have any issue there either. 

What template did you use for the event? (I used Generic Event as a template)

Best,

Maarten

I used Issue Updated originally but I switched it to Generic to see if that would help. Sadly, it did not. Hopefully I will hear back from my support ticket soon. 

Hi Kathy, were you ever able to get this resolved? We are having the same issue and it doesn't seem to be a resolution issue.

Changing resolution was what fixed it for me. 

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Thursday in Jira Service Desk

How the Telegram Integration for Jira helps Sergey's team take their support efficiency to the bank

...+ reading Fantasy). The same is true for him at the bank he works for: Efficiency is key when time literally equals money. Read on to learn how Sergey makes most of the time he has by...

213 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you