Custom Fields Stopped Working for Automation

Claire Parchem April 12, 2024

I had several projects (team and company) that had Epics with 2 custom fields and an automation set up to update them: Current Update and Prior Update. We run a little automation where if we type "Update:" in the comments the "Current Update" field is filled with the update and if we post another comment with "Update:" the Prior Update field gets updated with whatever was once in the current update field. 

 

This worked for ~ 6 months but mysteriously this morning it stopped working across all projects despite no changes being made to the automation/custom fields/projects. 

 

I am curious if something changed to invalidate the jql we have?  But it basically just started saying that the fields are invalid when they are not and have been used for months... It even worked as of just yesterday! We use the update automation a lot so its definitely a sudden change. Screenshot 2024-04-12 094436.pngcurrent.pngprior.pngScreenshot 2024-04-12 095613.png

 

Automation Rules: 

 

1 answer

1 accepted

4 votes
Answer accepted
Bill Sheboy
Rising Star
Rising Star
Rising Stars are recognized for providing high-quality answers to other users. Rising Stars receive a certificate of achievement and are on the path to becoming Community Leaders.
April 12, 2024

Hi @Claire Parchem 

I suspect you have been fortunate the rule has worked up until now as it has a problem...

When an Edit Issue action is used, it is based on the data at the time the rule started...unless the Re-fetch Issue action is included.  Your rule uses two edits in a row, and so is possibly colliding or walking-over prior results.

My suggestion would be to use one Edit Issue action, changing both fields, and enter the smart values directly in the field edits without using JSON.

 

Another possible challenge with your rule is you describe multiple fields have these names: company-managed and team-managed.  The company-managed projects will use the same field, but the team-managed ones each have their own field configured.

I recommend checking the project issues using this how-to article to confirm if the smart values are different between the projects.  Smart values are name, spacing, and case-sensitive and so a difference could lead to errors or unexpected rule behaviors.

https://support.atlassian.com/cloud-automation/docs/find-the-smart-value-for-a-field/

Kind regards,
Bill

Claire Parchem April 12, 2024

Thanks Bill!!!!!!! Directly entering the smart values into the field edits and using the custom field ids instead of the actual field name worked for me. What a relief. Thank you again!

Like Bill Sheboy likes this

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS
AUG Leaders

Atlassian Community Events