Crowd + JIRA + Conflunec SSO problem

Hi,

Our setup is CROWD + JIRA + Confluence. SSO for CROWD and confluence is fine. I have tried all things i found but to no avail. Also enabled DEBUG logging in CROWD with no additional info.

I traced the issue to the cookie domain being written. When I was trying SSO and forgot to add the SSO domain in Crowd, the cookie when logging into JIRA was from jira.xxx.comand the cookie from Confluence was confluence.xxx.com. After updating the SSO domain, confluence changed the cookie to .xxx.com. Jira changed to .jira.xxx.com.

Strangely when i do some actions, a cookie from crowd with the correct domain appear.

Has anyone encountered this issue or can suggest some places to investigate?

1 answer

1 accepted

This widget could not be displayed.

Hi Aldo, in case you see the cookie does not contain the same information when logging with Confluence comparing to JIRA, the following questions usually help to identify what's wrong:

  1. What are the URLs being used to access each application?
  2. What is the SSO Domain value stored in Crowd?
  3. Are both applications using the Crowd authenticator at their WEB-INF/classes/seraph-config.xml files? Are all the configuration inside crowd.properties correct?
  4. How many Directories are assigned to each application in Crowd? If more than one, are they in the exact same order?
  5. Are proxy servers being used between Crowd and the applications? If so, please add their IP addresses to the Trusted Proxy Servers list in Crowd.

Additionally, you can check the logs with debug enabled to get more information about this issue:

  1. Under Admin -> Logging & Profiling in Crowd, change the com.atlassian.crowd package to DEBUG.
  2. Replicate the problem you are having (Logoff from all the apps; Login to your third-party and then try to access JIRA; Logoff again from all the apps; Login to JIRA and then try to access your third-party app).
  3. Check the results into atlassian-crowd.log file.

I hope this helps

Cheers

Hi Tiago,

I tried adding DEBUG information but without success... I forgot to mention that the system is on a Windows Environment.

The issue was due to IIS configuration. We dont have time to see what was wrong with the configuration is ARR and we replaced IIS with Apache and SSO is working now.

Thanks for your time,

Aldo

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

63 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you