Create project in Jira, Mostly get a 401 This resource requires WebSudo

I'm set up as jira administrator, and trying to build out a demo environment to internally sell this as a solution to my team (historically I have administored jira at other companies). However I have successfully created some projects, but 90% of the time I get

" Error creating project, 401This resource requires WebSudo.". Then I try again a minute later and occasionally it works, or I add a different project and it works. ive checked the logs and so far nothing looks obvious.

System details: Windows server 2008, external SQL server 2008 DB, Jira demo install. using AD for authentication only.

14 answers

1 accepted

This widget could not be displayed.

We faced a similar error with the latest Jira 6.0.7. The only thing that worked for us was to trigger a re-index in the Jira System administration.

- Benjamin

works as a workaround, but it is really annoying. Re-indexing works for a while but sooner or later the same problem occurs. It seems that jira looses some cookies or whatever which causes jira to revoke your admin rights

Works here too

Thank you for this one!

As @Elvar posted: just relogin is fine.

Worked for me today!

This widget could not be displayed.

This can happen if you have the additional login prompt enabled for config changes (is by default). When you are going to do an action tha requires those rights (websudo) but the login has timed out the interface does not tell you. When trying to take that action without the websudo rights results in this error. Just clicking something to trigger the login and logging in again, and then do what you were originally trying to do will work.

This widget could not be displayed.

I think it's a bit vague. Websudo rights can be lost if you have network problems, or you're doing odd things in the browser, or if the server is experiencing problems, or if the authentication stuff is set up badly.

I suspect more looking at the logs may be needed, along with details about the browser and authentication setup.

I have the same issue. I recently migrated the database to Postgres, and now, 100% of the time when I try to create projects, I get: Error creating project, 401 This resource requires websudo. JIRA and Postgres are both located on the same system. I can see my existing projects and data, but just can't create a new project. Any ideas why?

Brian

I'm afraid it's the same answer. You'll need to do some debugging yourself - look in the logs for errors or mention of websudo, check your installation is done correctly and you haven't missed anything in the setup. Try a different browser and a different machine. Check your network logs.

Hmm interesting thoughts. My atlassian suite is indeed behind a HTTP reversed proxy with SSL on using a self generetad certificate.

Sadly, "indexing fixes it" is the wrong answer. I suspect it works because triggering the indexing process goes through something that refreshes or renews your session, and hence keeps the websudo, but as the index has *no* session data in it, the re-index itself is not the answer.

This widget could not be displayed.

No coments for this yet? I have the same issue here, no news???

This widget could not be displayed.

Actually to feedback on this. I solved it by creating a new local account with admin rights and removing any association with my original acount and then deleted it. As no other user account I had created seemed to have trouble. I did also trigger a re-index at a later date so this might have work if I had done that before the account add/delete. But for me it was just removing the affected user.

This widget could not be displayed.

I reindexed with a Postgre install on Win64 and it worked fine after that.

Start with reindex first.

This widget could not be displayed.

I got this error on 6.1.5 with a fresh test install on Windows. A re-index (of the zero issues and projects!) fixed it. Not the best user experience ... I've been a Jira admin for 8 years and I had no idea what "websudo" meant in the context of Jira, although I know sudo is the Linux command for elevating user privileges.

This widget could not be displayed.

re-index worked for me too

This widget could not be displayed.

I reindexed from within Jira admin, and also reindexed the db directly in postgres. After that it worked.

This widget could not be displayed.

Reindexing works.

This widget could not be displayed.

I faced similar issue, this is due to session timeout you can logout and login again.

This widget could not be displayed.

Just had the same shit; I re-indexed and hey, it worked. Thanks Benjamin!

This widget could not be displayed.

I had this issue with Google Chrome as browser. I did not find a way to get rid of the Websudo error message, although initiating creation of a new project always triggered the additional Admin credential confirmation.

When I changed the browser to firefox, it worked out-of-the-box with no further changes (i.e. no reindexing).

This widget could not be displayed.

 re-indexing works...any specific root cause for this?

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

92 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you