Create issue includes "Some issue types are unavailable" on all projects

Error message when Creating issues:  Some issue types are unavailable due to incompatible field configuration and/or workflow associations.

I believe I've read everything in "Answers" and in existing JIRA tickets regarding this caution message, but have yet to find the culprit in my system.

There are two things going on in our JIRA instance that I believe are related but could be two separate & distinct problems.

1)  Regardless of which project is chosen when you go to create a new issue, you get this warning message.  It doesn't appear to prevent us from creating specific issue types except for project "X".  See #2.

2) In new project "X", we have 11 issue types.  6 of which use a PM style workflow and screen scheme, 5 of which use a developer style workflow and screen scheme.  No special issue field configuration schemes have been applied, all issue types are using the same default field configurations that most of our other projects use.  Here's the weird thing: users in the Developer role can only create 2 of the 5 developer-style issue types and none of the 6 PM style issue types.   Users in the "PMO" role can create all EXCEPT those 2 issue types.  There used to be an issue security scheme applied that set a different security scheme for those 2 issue types and applied it as a post function in a unique workflow upon issue creation.  I've since removed that unique workflow and the security scheme but the situation remains the same.  Supposedly it's not possible to restrict within a project which types of issues a user can create.  Yet I've managed to do it and I don't know how.

In the Developers role - only the group "X-Contractors" is included.

In the PMO role - both "X-Contractors" and "X-PMO" are included.

In the Users role - both "X-Contractors" and "X-PMO" are included.

Most of the permissions are granted to the Users role.  Developers have Move and Schedule permissions, which PMO and Users do not.

Another weird thing I've noticed ... when I get the create issue pop-up, the screens aren't consistent.  the following URL ( https://oururl/browse/ANOTHER/?selectedTab=com.atlassian.jira.jira-projects-plugin:issues-panel ) does NOT present the same create screen that is defined for the Create Issue event and shows up in the pop window with this URL (https://oururl/secure/BrowseProjects.jspa#all).  

Obviously I have no idea what's relevant and what isn't.

Any and all suggestions appreciated.

Karla

4 answers

1 accepted

Accepted Answer
0 votes

I solved this by doing a database level reindex.  Not a JIRA-level reindex. We use postgresql so the command was:

reindexdb jira

 

So, no hack had been applied.  The indexes somehow got out of whack and re-index via JIRA didn't fix it.  Neither did a restart of JIRA.  I tried all of those before solving it this way.

0 votes

>Here's the weird thing: users in the Developer role can only create 2 of the 5 developer-style issue types and none of the 6 PM style issue types

You have a none-standard hack in your JIRA that does this.  JIRA doesn't have this level of permission - you can either create an issue in a project or you can not.

To get to the bottom of what is going on, you'll need to work how this hack has been implemented first, as there's a good chance it is causing or influencing the rest of the behaviour you're seeing.

I'm not sure what you mean. We are using Jira v 6.3.9. So relatively current. How could a "hack" be applied? We don't make database level changes. Everything is done via web interface.

That's the whole point - Jira simply does not stop you from creating issues based on type. You are describing behaviour that Jira 6.3 doesn't do. So you must have added it So, you *must* have something that is changing that behaviour. There are two approaches - one is to allow people to start creating an issue type, but then block it. That doesn't need code, but it does not sound like that is what you are doing. The second is to amend the behaviour with some code (not database changes, but actual code). What addons have you got? Have you made changes to code? Is there javascript being injected?

We have not made code changes. Re. javascript being injected , not to my knowledge. THe add-on question is interesting. The URL I posted in above ( https://oururl/browse/ANOTHER/?selectedTab=com.atlassian.jira.jira-projects-plugin:issues-panel ) appears to point to some sort of add-on called issues panel which I couldn't find anywhere. Any clues about that? And what do you think about a JIRA restart? Could that help?

0 votes
Justin Burke Atlassian Team Dec 29, 2014

Here is some additional reading from our knowledge base regarding this error message:  https://confluence.atlassian.com/pages/viewpage.action?pageId=278692623

It may give some insight into possible causes.

That's one of the articles I've already read. Including all the comments and their suggestions. :( Is it possible that a shutdown and restart could make things happier? (The "when in doubt - reboot" solution.)

This is not an answer.  It's an update.  

1) Problem persists. 

2) I completely deleted the issue security scheme that I had created and then stopped using altogether.  Now X-Contractor group members can create all 11 issue types, and X-PMO group members can create the same 9 issue types.  All permissions are applied via Roles in the permission scheme.  And all "Users" can create issues.  All roles that contain X-Contractor also contain X-PMO, and vice versa.  There is not a single role that contains only one or the other.

 

 

 

 

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

27,176 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you