ComponentAccessor has not been initialised

I am getting error in REST plugin.

ComponentAccessor has not been initialised.

I am using static method ComponentAccessor.getComponent

5 answers

i think you have to try with getComponentOfType(Class<T> componentClass)

check this doc

https://docs.atlassian.com/jira/latest/com/atlassian/jira/component/ComponentAccessor.html

can you share your code ?

import com.atlassian.jira.component.ComponentAccessor;

if (fieldConfigId != null)
{
FieldConfigManager fieldConfigManager = ComponentAccessor.getComponent(FieldConfigManager.class);
fieldConfig = fieldConfigManager.getFieldConfig(fieldConfigId);
}

can you try with getComponentofType(FieldConfigManager.class) method

I tried ComponentAccessor.getComponentOfType same error

Just out of curiosity, where in your class are you trying to receive the ComponentAccessor?

why can't you instialize this through constructor?

check here, in this class it is insitialized through constructor and used

https://bitbucket.org/topmanage/tm-project-templates/src/4e51f3d7e365/src/main/java/com/topmanage/jiraplugins/projecttemplates/ProjectCloner.java

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,734 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you