Classic Epic Migration not working

I just upgraded to the latest greenhopper. This is my first version with the Epic support for rapid boards. I attempted to run the Classic Epi Migration tool, but it claimed everything was already ok. It says this,

<dl><dd>37 of 47 epics have 595 Classic epic links</dd><dd>595 Classic epic links already exist in the new board</dd><dd>0 epic links will be migrated</dd><dd></dd><dd>However, when I go to the planning board, all I see if my epics down the left all titled something like "unlabelled-xxxxx" and they have nothing in them. Do I really need to manually hook everything back up? I had an idea to search for issues based on the old epic field and to a bulk change of the new field, except the new Epic Link field doesn't seem to be changeable from the bulk operations page. Is there another way to do this?</dd></dl>

2 answers

This widget could not be displayed.

Hi Mark

GreenHopper requires a reindex (either a full reindex, or a completed background reindex) for epics and epics related functionality to work properly. Only issues reindexed after the "Epic Link" field has been added to the system will be valid candidates for migration.

Your work around worked because editing and issue also reindexes it.

I have the same issue as Mark. After a full re-index, it still shows

0 epic links will be migrated

But this issue only applies to projects where I already did some manual Epic-Issue-Association (I found out about the Classic Migration, after doing a little testing).
For projects, where I never touched an issue after updating GH, Classic Migration works as expected.

Only issues will be migrated for which no new epic-issue association already exists, the others will be ignored. This logic applies on a per-issue basis, not on a per-project basis though, so in your case I assume you manually linked up all issues (that have an Epic/Theme value) of some projects to their respective epics already?

I associated just a few issues, but the remaining "unassociated" issues would not be migrated as well.

But: After full re-index -> Jira restart -> full re-index it suddenly worked. How knows...

This widget could not be displayed.

I found a work around for this. Apparently, the migration is only migrating issues the have been changed in some way after the upgrade to the latest green hopper. So, what I did was used bulk change to add a label to every issue that had an non-empty Epic field. I limited the JQL to a single project and the latest version for now. My JQL looked something like this.

project = XL and fixVersion = Jun13 and Epic is not empty

On the bulk change, I added an arbitrary label, named "hasEpic".

After I did this, when I ran the Epic Migration tool, it updated all the epics that I just added that label to.

Prior to doing this, I manually entered names for these epics from the planning board since they all said, "Unlabelled" For some reason, that was not done automatically.

Also, a word of caution. I have no idea how bulk change handles labels. Does it replace all of them, meaning if one of these issues already had a label for something else would it remove that label, or will it just add the label I added. Since my items didn't have labels, I'm not sure. If your items have labels, you may want to check this on one or two first to determine if it will be a problem. Or you can change another field. I tried changing stuff that didn't require changining like in my case, fixVersion = Jun13, but that basically resulted in no change and didn't help making the migration tool work.

Hi Mark,

Bulk Edit of a Labels field will remove any existing values set for the Labels field and replace them with the ones you input into Bulk Edit.

Cheers,

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

307 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you