Cannot get bamboo gadgets to display in Jira.

I've tried every combination of parameters in the application links that I can think of, and I just can't get several gadgets to work.

Running Jira 4.4.5 and Bambo 3.4.3

First, Bamboo is clearly communicating with Jira because it displays issues and information from Jira on build pages.

Second, one Bamboo gadget (Build Plans) will work in Jira, and on the 'Builds' tab of an issue it succeeds in getting a list of builds from Bamboo.

But, when I try to Add Bamboo Charts or Bamboo Plan Summary Chart, I get:

2012-07-18 22:09:02,554 http-8080-6 WARN kwood 1328x205299x5 16jwss6 10.34.18.92,10.120.66.75 /plugins/servlet/gadgets/makeRequest http.impl.client.DefaultRequestDirector Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm=https%3A%2F%2Fbamboo.dev.e2open.com}

2012-07-18 22:09:03,776 http-8080-6 WARN kwood 1329x205300x5 16jwss6 10.34.18.92,10.120.66.75 /plugins/servlet/gadgets/makeRequest http.impl.client.DefaultRequestDirector Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm=https%3A%2F%2Fbamboo.dev.e2open.com, oauth_problem=consumer_key_unknown}

2012-07-18 22:09:05,722 http-8080-30 WARN kwood 1329x205304x2 16jwss6 10.34.18.92,10.120.66.75 /plugins/servlet/gadgets/makeRequest http.impl.client.DefaultRequestDirector Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm=https%3A%2F%2Fbamboo.dev.e2open.com}

Please advise what I need to do to correct this.

2 answers

This widget could not be displayed.

Your gadget.xml is probably missing the badly documented

<Optional feature="atlassian.util" />

rgds

That sounds intriguing, I'd like to investigate further... however, this isn't "my" gadget, it is the standard gadgets made available by Bamboo. Where would I find each gadget's XML file?

That depends on the packager. I suggest unzipping the jar and searching for the file.

The only XML file in atlassian-bamboo-charts-3.4.3.jar was pom.xml which clearly not gadget.xml. So, no luck finding the gadget.xml where I might try adding the missing line you referenced.

Adding the following line :

<Optional feature="atlassian.util" />

into my gadget ModulePrefs fixed the problem !

Thanks

This widget could not be displayed.

Hi, there definitely is an issue with the Application Link. Have you set it up as Trusted Applications? It looks like OAuth is used. Are the required URLs entered for the application link?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

266 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you