Cannot find symbol error in compile time

hi all,

when i tried to compile my jira plugin i've got this:

[ERROR] BUILD FAILURE

[INFO] ------------------------------------------------------------------------

[INFO] Compilation failure

/home/........./src/main/java/com/............. .java:[8,39] cannot find symbol

symbol : class elements

location: package org.codehaus.cargo.module.webapp

and i tried to add its dependency ,but doesn't work

<dependency>
<groupId>org.codehaus.cargo</groupId>
<artifactId>cargo-core-api-container</artifactId>
<version>1.4.4</version>
</dependency>
what can i do to resolve it?
thank's in advance,

3 answers

did you ran atlas-mvn eclipse:eclipse command?

thanks rambanam

yes i did try

can you try this

&lt;dependency&gt;
&lt;groupId&gt;org.codehaus.cargo&lt;/groupId&gt;
&lt;artifactId&gt;cargo-core-api-container&lt;/artifactId&gt;
&lt;version&gt;1.4.4&lt;/version&gt;
&lt;scope&gt;provided&lt;/scope&gt;
&lt;/dependency&gt;

after adding this to pom.xml run atlas-mvn eclipse:eclipse command

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

191 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you