Cannot approve application link between jira and bamboo

I've set the application link and added a project link, jira asks me to login and approve when i click Builds. After that i'm presented with the following error:

An error occurred while trying to obtain an access token. For application link "Atlassian Bamboo (2d6976b6-69ba-3c33-be98-30cd35d72fc4) https://hostname.domain:8443/bamboo com.atlassian.applinks.application.bamboo.BambooApplicationTypeImpl@45fed551"

I'm running jira on an ubuntu virtual machine behind tomcat; Bamboo is running on a windows server 2008 r2 machine, with ssl.

Any suggestions on how to resolve this issue? When I try to use basic auth or trusted application, it doesn't allow me to make a project link.


Ferdy

2 answers

1 accepted

This widget could not be displayed.

Hi Fredy,

What I would recommend at this point is opening a support ticket at support.atlassian.com so we can have a close look at the logs and yor configurations as well. When opening the ticket please attach your bamboo server and Jira logs and also screenshots of your application links settings in both Bamboo and Jira.

Best,

Sepideh

This widget could not be displayed.

Hi Fredy,

1. Are you using the same user base for Bamboo and JIRA? Make sure to use the correct authentication as per this page: https://confluence.atlassian.com/display/JIRA/Configuring+Authentication+for+an+Application+Link.

2. Are you using the correct Base URLs for Bamboo, matching the URL that you have in Administration -> General Configuration page and for JIRA when configuring application links: https://confluence.atlassian.com/display/BAMBOO/Integrating+Bamboo+with+JIRA? If no, please delete the configured applinks (make sure that they are gone from Bamboo and from JIRA), update the Base URLs if you need to (to match the hostname for each app) and configure the app links again.

3. If you are still facing the same problem, please try to use the IP addresses of your apps instead of the hostnames to eliminate the possibility of DNS resolution errors.

4. Another thing to try is to make a back up of the Bamboo db, shut down bamboo and run these queries:

DELETE FROM trusted_apps_IPS;

DELETE FROM trusted_apps_URLS;

DELETE FROM trusted_apps;

DELETE FROM bandana WHERE BANDANA_key LIKE '%applink%';

5. Since you are using SSL, make sure that the cert is correctly imported into the ketstore.

*This article might also be helpful to you: https://confluence.atlassian.com/display/BAMKB/Troubleshooting+Bamboo+Gadgets

Hope this helps!

Best,

Sepideh

Hello,

Here are my results:

1. Bamboo is using the JIRA User Server as userbase, so yes, they're indeed the same.

2. Both Jira and Bamboo base url's are set correctly. I've tried using with and without contextpath.

3. IP Addresses is a bit tricky, cause with SSL there has to be a valid hostname or else the SSL errors will occur.

4. Tried this, some records in the bandana table were removed, however this had no effect.

5. I've looked at the logs of Jira and they indeed show an "signature_invalid" problem with OAuth. I've tried to run it without SSL on bamboo since i'm still setting this up. Jira is working perfectly on SSL and can communicatie with fisheye and confluence. I've tried using Bamboo with and without reverse proxy (IIS) and with and without SSL enabled, still same problem. Any suggestions?

Ferdy

Hello,

Here are my results:

1. Bamboo is using the JIRA User Server as userbase, so yes, they're indeed the same.

2. Both Jira and Bamboo base url's are set correctly. I've tried using with and without contextpath.

3. IP Addresses is a bit tricky, cause with SSL there has to be a valid hostname or else the SSL errors will occur.

4. Tried this, some records in the bandana table were removed, however this had no effect.

5. I've looked at the logs of Jira and they indeed show an "signature_invalid" problem with OAuth. I've tried to run it without SSL on bamboo since i'm still setting this up. Jira is working perfectly on SSL and can communicatie with fisheye and confluence. I've tried using Bamboo with and without reverse proxy (IIS) and with and without SSL enabled, still same problem. Any suggestions?

Ferdy

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted yesterday in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

61 views 2 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you