Cannot Get Collector to Display on Webpage

This question is in reference to Atlassian Documentation: Using the issue collector

I have been trying to get a newly created issue collector to show up on a simple html webpage as a demonstration of the functionality.  I created a new business project for task management and created an issue collector with little changed from default.  However, not matter how we embed the code; we cannot get the issue creator to show up.  We have tried both solutions and each time, the collector does not load.  Page profiling shows the code executing without error and Visual Studio does not report any errors from the build.  I found this questing (Issue collector does not show up) but removing the locale did not fix our problem.  

 

<script type="text/javascript" src="https://idcfs-oits.atlassian.net/s/0f9a69d3a5f98a3570ba51310d79c4ab-T/en_US-49fam4/72000/b379df1a609edfa4d036eeb2a01ca2c8/2.0.12/_/download/batch/com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector/com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector.js?locale=en-US" data-wrm-key="com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector" data-wrm-batch-type="resource&collectorId=d729e1c1"></script>

with locale removed:

<script type="text/javascript" src="https://idcfs-oits.atlassian.net/s/0f9a69d3a5f98a3570ba51310d79c4ab-T/en_US-49fam4/72000/b379df1a609edfa4d036eeb2a01ca2c8/2.0.12/_/download/batch/com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector/com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector.js" data-wrm-key="com.atlassian.jira.collector.plugin.jira-issue-collector-plugin:issuecollector" data-wrm-batch-type="resource&collectorId=d729e1c1"></script>

 

Any help would be appreciated.

2 answers

What configuration are you using? Prominent? Subtle? Have you tried a custom one? is javascript enabled in your browser? 

Direct embedded html, Prominent, I have not tried the custom (trying to keep it simple) and yes, js is enabled.

Time for some debugging then. What console do you have? Try opening up the browser console and check what error is being logged when you open the webpage with the issue collector, I suspect communication issues.

I was using VS2013 and debuggin in Chrome and IE.  Everything showed green with no run-time or compile errors.

I did find a JIRA issue that address this problem though.  You have to manually modify the link to replace some quotes and spaces but afterwards, the collector works as intended.

 

https://jira.atlassian.com/browse/JRA-59966

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,885 views 19 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you