Can't move JIRA Scrum Board Issues

I have a user who is a project admin and the owner of a board and the admin. However he cannot move any issues. I'm stumped.

6 answers

Had an issue where Jira "Issues" were in a few cases not moving across from one column to another. Some moved, but not all. I clicked on the elipses (...)on the side after clicking on each Issue item that did not move - found 'More Actions' from the pop-up menu, and there was a section that named columns (such as 'Done'). I used that to resolve by clicking the column name where the item should reside. It worked...

So drag and drop may not work, but using the short-cut menu may help. (This was in the cloud...)

I have this problem as well using JIRA cloud. Using the Elipses (...) function works fine, only drag & drop doesn't. 

"move" is not the same thing as "transition".  Check the conditions on your workflow.

You are right, apologies, however I think a number of people are talking about transition here.

There are no conditions. It's not a workflow issue as a) the same happens with other workflows on the board (even though in other boards the same workflows allow me to transition) and b) the transition using the ... menu works, only drag and drop fails.

The ... menu on issue view does not contain transitions, so I'm not sure what you're clicking.

1) Click More Actions

2) Type [Desired Status]

3) Appears under "Workflow" section

 

Ok, so not the ... menu, but the workflow one.

You'll need to check exactly what is happening here.  Ignore the workflow status for now, and look at the transition name on the workflow menu.  Then go to the workflow editor to see where it takes you, and check where it lands and then what column that status is in.

No, I am pressing on the ... menu on the top right of the issue in the Kanban view to get there.

By workflow menu, I assume you mean in the issue detail view (next to the Edit function etc.) If I press Done here, it will transition correctly. 

Just to summarise: Only the drag and drop function, only in this Board, with any user that has access to the project, doesn't allow transitioning.

Two points I noticed:

1) I have an old issue (Dec 2015) where the drag and drop does work!

2) When trying drag and drop "sometimes" (yes I know this isn't scientific but I don't know the exact mouse path to follow to make it appear) it shows attached error when I try and drop the card view on the intended transition status. Screen Shot 2017-07-09 at 15.29.18.jpg

 

That still suggests the workflow does not have a transition (or does have one, with a condition you're not meeting) for <something> -> <status in the done column>

I'm not a complete expert but have experience with workflows and don't see an issue. 

Just to add, the old issue that works correctly is in the In Progress column and I can move it to done. Doing the same with a more recent issue produces the error shown (with some trial to trigger it).


That also doesn't match up with the fact that if I apply another workflow to the same Board (which behaves as expected in other Boards), the same issue occurs. 

Screen Shot 2017-07-09 at 15.44.41.jpg

Ok, what are the board columns?  One for each of the three status above?

Ok, you'll need to read the log to see what errors are being thrown when you try to do the column to column drag and drop.

What if I'm in the Cloud?  Where's the log?

Have you eliminated all the stuff Florian checked first?  Conditions, permissions etc?

Yes.  And I clearly have permission since I can open the issue and manually change the state . I just can't do it on the Kanban board.

It even moves to right place on the Kanban board after I edit the issue.

Could you quickly try another browser?

Sure.  Unfortunately it fails exactly the same way on Firefox (I was using Chrome at first).

Ok, that's good and bad news.  The good is that you've now pretty much ruled out a problem on the client side.  The bad is that it means we need to look at logs and try fussy things that we can't actually do on Cloud.

You'll need to raise a support request via https://support.atlassian.com/contact

I did, and they figured out that this is a problem for people who have imported their workflow from Trello.  Here's the issue for future people with the same issue:

https://jira.atlassian.com/browse/JSWCLOUD-16620

Until that's fixed, the only workaround is to open a support ticket and they'll fix the ID manually in the DB.

0 votes

It all depends on their permissions. System admin and project admin don't mean anything unless your permission scheme and/or workflow explicitly states "people with project/system admin can do this" (admin automaticaly can do stuff is a terrible security model and one not implemented in Jira)

Look at the workflow for the issues - it probably has sensible conditions like "must be a developer" and/or "must be a user". Once you have the rules, check whether your user matches any of the rules (if not, add them to roles/groups so that they do).

Thanks Nic, but that's the curious thing about this all. This particular user is a member of the admin, developer and users group for the project. So I would think that would catch it all and he still can't move any of the issues on the board. I'm at a loss.

You still need to check the conditions in the workflow. They could be role based instead of groups, they could be something else again.

I ran into something similar and it came down to a simple thing and that was clearing all filters. Then all of a sudded I was able to move things around again.

Also ran in to this problem. Turns out we forgot to put in the right transition from the state most issues were in. 

Solution: Make sure a transiton is possible in your workflow. 

Came across the same problem, mine was a case of not understanding permission description. I had confused the ideas of 'Move Issue' & 'Transition Issue'. To me, move issue (and the description) sounded like what I wanted them to be able to do, but when read correctly it clearly says "between workflows", not in the same workflow as I had assumed.

This also explains why the Permission Helper tool was of no use to me, it kept saying everything was OK for the user to be able to move the issue.

So perhaps double check you've allowed this. 

Hi, We are experimenting the same issue that had Mary Wilson on 2014 (not sure if she resolved ) . It started to block users last week using IE , but not using Chrome. Today, a Lead user got this issue even usign chrome. all leads can move issues on the workflow , but only her has the issue. in addition, I create as admin a new user to test and assign it to the lead group as part of the admin project role, permissions are based on this admin role fo rtransitions on the workflow, but it didnt work.

so on summary, old users with lead- admin role can do changes except one, and new users assinged to this project admin lead role can't.

any ideas what could be? 

note even using the mobile application it didnt work

It's the conditions on the workflow transitions.

how can you explain other users on the same group and same admin project role dont have this issue?

it is only one user , yesterday I added two exiting users and it works for them.  in addition, it was working for her well until last week on chrome;  on IE, the kanban doesnt work for anyone since last week and the workflow havent been edited since may 31th.

 Last change on workflow was to add a trigger on closing  or cancel issues with resolution by default

in addition for her, the kanban doesn't load any status on the columns, it could be a clue for you?  

 

 

Sorry, I misread the bits about the browser.

It sounds like there is a problem with the browser/code combination.  Are you on Cloud?

yes , we are using jira cloud.

Ok, this is something I think they've released recently which has broken some of the javascript.

Could you send it over to htts://support.atlassian.com ?

Ok I did, I got my ticket, hope they can help , thanks Nic

Sorry I couldn't do a lot more, the original question turned out to be conditions, but you've definitely got a different issue here, and as it's likely to be a bug on cloud...

ok thanks , hope support team can help me

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,012 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot