Can't link issues in project despite having permission

I have a user who is trying to link multiple issues in a particular project. They're getting a "you do not have permission to link issues in this project" error, despite the fact that jira-users has that permission granted for the project. Any ideas why?

I'm not sure what else would be helpful to know, but please ask and I'll provide any info I have.

8 answers

1 accepted

It turns out that the issue was related to a bug in my version of JIRA:

I managed to reproduce the problem and find the cause for it.
It seems we have a bug on JIRA that does not allow users without Edit permission to link issues at the issue creation

The issue is set to be fixed on JIRA 6.

check this ... go to administration and click on 'issue linking.' make sure it's turned on like you see below.

(silly answer, i know. but it's always the silly stuff that ends up biting me in the ass.)

It's on. Plenty of other users have no problem linking issues, even in this project. It appears to just be this one user that has issues.

does the problem go away if you were to adjust the permission to group (anyone)?

sadly no, the problem doesn't go away

weird. are you sure you're trying to link issues within the *same* project? (hell. i've never tried to link issues across projects so i'm not sure if it's even possible.)

oh! is this user part of the 'users' group?

i'm not sure what you mean. here's a list of the groups this user is a member of (obviously most of them won't mean anything to you):

  • ccp ambassador team
  • Change Approval Board
  • Client Service Leadership
  • confluence-administrators
  • confluence-users
  • Consulting
  • Enhancement Team
  • Jira Users
  • jira-administrators
  • jira-users
  • Managers
  • Sales Leadership
  • SET
  • Support Group
0 votes
Joe Pitt Community Champion Apr 11, 2013

I notice he isn't in the Training group, which has edit permission. And, yes you can link across projects as long as you have access to the other project. I think all you need is browse in the other project.

yes, she's in the jira-users group, that's the group that gives login access. And yes, she's not in the Training group, and therefore doesn't have edit permissions in the Training project, but she does have Browse permissions in that project, as well as create permissions. The error is occuring whether she tries to link to an issue in the Training project, or to an issue in a different project (where she has full rights).

make sure the user is part of 'jira-users' group then and see what happens. again, make sure they're trying to link two issues within the same project as well.

I have *one* user with the same problem, although a slightly different symptom. They get the Link dialog, auto-completion of issue key works, but as soon as they want to "save" the link, they get a "you must specify a JIRA issue to link to" error message. (and the issue key is gone from the field)

Their permissions are correct, issue linking is enabled and works for all other users afaik. Nothing shows up in the logs. Happens for any and all projects/issues for that user, while the same works for other users with the groups and roles. Tried with different browsers and machines, no dice.

I'm stumped.

We just noticed that when logged in as that user, the "issueLinkIDs" field was just not passed in the POST request. Odd.

In this cases what you can do it's create a test user and add the same permissions as the user, create a user exactly like his and try to reproduce it. It's weird that only this user can't do that.

There's at least 10 other users with the same configuration as him ;)

... and now it works again.

So famous hahaha...

I'm having same issue with a couple users.. anything that you did specifically?

@Miguel: frankly, I have no idea. Time passed and/or the server was restarted. :|

Just like you said. Time passed and now it works at least for one of the users!

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,878 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot