Can't import backup from OnDemand to Standalone

Hello.

I've made an backup on Jira OnDemand, copied it on my Standalone server and after this I tried to restore it in system / Import & Export / Restore System. I entered the backup file name and I got the error: Error importing data: java.lang.IllegalArgumentException: [GenericEntity.set] "jobData" is not a field of.

Also I tried Project Import on the same Standalone server from the same backup file and I got the error: cind fac project import: This data appears to be from an older version of JIRA. Please upgrade the data and try again. The current version of JIRA is at build number '6252', but the supplied backup file was for build number '6321'.

What I'm doing wrong ? Or may be because of different build number it is not possible to migrate from OnDemand to Standalone ?

8 answers

Brian, In my case the problem was in MySQL charset. I installed the last 6.2.6 Jira version and created mysql DB with UTF8 charset. After this I installed Jira and before starting the configuration I added in the setenv.sh script the option JVM_SUPPORT_RECOMMENDED_ARGS="-Dfile.encoding=utf-8" to be sure tha the jira will use UTF encoding. After this I was able to import the backup from OnDemand. But now I have anothers issues - it seems that it didn't imported the users logos and the projects attachements.

Please check this link https://confluence.atlassian.com/display/JIRAKB/SQL+Exception+while+Updating+Issues+or+Importing+Data+in+JIRA+with+MySQL+Due+to+Encoding

Thank you Alex, I can confirm this helped.

I started a local JIRA 6.2.7 instance with the additional Java parameter '-Dfile.encoding=utf-8', after that the import worked.

Hello.

I've follow the instructions on the page linked below. No results.

Alex - What happened? How did you resolve this?

Brian, I haven't resolved it yet. I openned an task to support, now I follow their instructions, trying to resolv the problem... still without success...

Hi Alex

I am also getting the same error - Error importing data: java.lang.IllegalArgumentException: [GenericEntity.set] "jobData" is not a field of

did you get a resolution for this? pls do let me know

thanks

Alex, thanks for letting me know.

I have the latest version of on OnDeman. I'm following the instructions from Here Be Dragons (https://confluence.atlassian.com/display/ATLAS/Dragons+Stage+1+-+Install+JIRA) which stipulates using Jira 6.1.5. for the stand-alone version. Is this what you have as well? Thanks for getting back to me.

0 votes
Ruchi Tandon Atlassian Team May 21, 2014

Since OnDemand installation is currently running 6.3 version of JIRA, you would need to import your data to 6.3 or above installation of JIRA behind the firewall. In order to do that, you need to go to this link, https://www.atlassian.com/software/jira/download-eapand download the 6.3 EAP(Early Access Program) release and then try to import your data into this version of JIRA.

NOTE: Please note that the EAP releases are not officially supported. So as soon as a 6.3 release for JIRA behind the firewall comes out, you would need to upgrade to that release n your side.

Hope this helps!

Thanks Ruchi.

It helps, but the page stated these releases should not be used in production environments. any idea when they will be supported?

I didn't state this exclusively but I was able to complete the import of my JOD data after installing the latest version of JIRA stand-alone.

hi 

I have this problem when importing data from JIRA 6.2.6 backup in to JIRA 6.2 for downgrade 

"

ErrError importing data: java.lang.IllegalArgumentException: [GenericEntity.set] "jobData" is not a field ofor importing data: java.lang.IllegalArgumentException: [GenericEntity.set] "jobData" is not a field of

"

Untitled.png

 --use jdk 1.7.71

---mysql 5.5

pls help me

Hi, I also encountered the same error, Did you figure it out what to do?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 29, 2018 in Jira

How to set up an incident workflow from the VP of Engineering at Sentry

Hey Atlassian community, I help lead engineering at Sentry, an open-source error-tracking and monitoring tool that integrates with Jira. We started using Jira Software Cloud internally last year, a...

1,117 views 0 8
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you