Can't connect to Jira in browser

Hello,

I need help with Jira; it's not responding when I attempt to connect via my browser now.

Here's some background information:

I installed Jira in a 64bit Ubuntu 12.04.03 VM; I'm doing a 30 day evaluation. The installation went smooth, everything worked great, I could connect right away. It was running slow, however. I shut the VM instance down, added a CPU core and another 1GB of RAM, and started it back up. I've verified the increased resources are showing in the VM instance. 2 problems have occurred since:

1. Jira was only running on tcpv6 port 8080. I resolved this with a little googling and added '-Djava.net.preferIPv4Stack=true' to the JVM_REQUIRED_ARGS in setenv.sh. Was this the best way to handle this problem?

2. Jira is running on tcp port 8080, as verified by netstat -apn, but everytime I hit my URL (real name removed) http://jira.company.com:8080, the connection times out. I can't find any problem in any of the logs. I ran tcpdump on the VM on port 8080 and see the request coming in, but no response. The firewall has the port open. Where/what else can I check to see why I can't connect?

I'm hypothesizing the VM change I made has affected this, but don't know why; I'm not a big fan of coincidences. I've stopped/restarted Jira several times.

Questions? Thoughts? Any help is appreciated.

-Steve

3 answers

0 votes
David Chan Atlassian Team Dec 09, 2013

Can you try accessing your Ubuntu system directly and access JIRA via http://localhost:8080? Basically I'd check if the problem is related to the network

I'm having an almost identical problem to this. I'm hosting JIRA using a vpc from Digital Ocean. After rebooting and several service/stops& starts of various kinds using the scripts and daemons, I cannot get access to the web interface. I've tunnelled into the local host on the box and it produces exactly the same html error page that I see from externally. In the address bar it indicates a redirect to: http://localhost:8880/secure/errors.jsp has occurred. There is a html response I'm presuming according to this wget output: liang@Atlassian3:~$ wget 127.0.0.1:8080 --2015-04-07 04:06:40-- http://127.0.0.1:8080/ Connecting to 127.0.0.1:8080... connected. HTTP request sent, awaiting response... 302 Found Location: http://127.0.0.1:8080/secure/errors.jsp [following] --2015-04-07 04:06:40-- http://127.0.0.1:8080/secure/errors.jsp Reusing existing connection to 127.0.0.1:8080. HTTP request sent, awaiting response... 500 Internal Server Error 2015-04-07 04:06:40 ERROR 500: Internal Server Error. Would really like to work out what's wrong. Thanks!

Hi Liang,

It was actually my firewall that was the problem (using built-in iptables).  I disabled the firewall and it worked fine.  I re-enabled the firewall and it continued working, even after JIRA stops and starts/restarts.  It hasn't been a problem since.

Hope that helps!

~Steve

Hey Steve, Thanks for the response :) I've since tested JIRA on my workstation. It has more cores and more RAM(4 cores, 8 threads, 12GB ram vs 2 cores, 2threads 2GB ram), and also using ubuntu (desktop version). I'm not sure if it was the change in hardware that allowed it to work after starting & stopping the JIRA service, but it does now, or if it was something to do with the VPC. Strange....

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,661 views 18 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you