Can not login to my Jira 5.1 installation

I have install Jira 5.1 with an evaluation license using linux installer. The installation worked out fine. When I try to login using the user I just registered, it does not login in, the page does not show any error message.

In the log I see the following messages

Unable to automatically login after setup complete: sessionStorage is null
2012-09-17 14:32:27,780 http-8080-4 WARN anonymous 872x41x1 - 127.0.0.1 /secure/Setup3.jspa [web.action.setup.SetupComplete] Unable to automatically login after setup complete: sessionStorage is null
Sep 17, 2012 2:32:53 PM com.sun.jersey.spi.container.servlet.WebComponent filterFormParameters
WARNING: A servlet POST request, to the URI http://localhost:8080/rest/gadget/1.0/login, contains form parameters in the request body but the request body has been consumed by the servlet or a servlet filter accessing the request parameters. Only resource methods using @FormParam will work as expected. Resource methods consuming the request body by other means will not work as expected.

Any Idea?

2 answers

1 accepted

This widget could not be displayed.

Hi Shamim,

Do you have any other Atlassian product running on your server being accessed by this same IP address (or via localhost)? I'm not sure but I think that this case may be related to this JIRA KB. In advance, would you try to login in JIRA through an incognito sesstion?

Best regards,
Lucas Timm

Yes, I have Confluence installed as well, but I was not running Confluence while running Jira. The documentation of your link described a situation when you would try to run the both apps on different ports but on the same domain context. That was not the case here, even though both were accessed using localhost.

Jira allowed me to login when I removed cookies for localhost.

Hi Shamin,

Good to know that it worked and was only a cookie problem. :)

Best regards,
Lucas Timm

This widget could not be displayed.

Hi Shamim,

The error in your log informs Setup3.jspa, it doesn't seem related to the login issue since it is the form to configure the Outgoing mail server:

2012-09-17 14:32:27,780 http-8080-4 WARN anonymous 872x41x1 - 127.0.0.1 /secure/Setup3.jspa [web.action.setup.SetupComplete] Unable to automatically login after setup complete: sessionStorage is null

At any rate, we have this documentation that has the instructions to reset the administrator's password, you may give it a try and if after this you are sitll unable to login, I'd suggest to open a support ticket at https://support.atlassian.com

Cheers

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

146 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you