%%CURRENT_USER%% does not seem to work for User Picker custom field

Hello,

I noticed the following issue in JIRA that does not seem to work as I expect.:

  • I have a custom field 'Users' which is a User Picker field for multiple users.
  • I have a filter on my Task board that filters on assignee and also filters on this users field. The filter looks like this: Assignee = Rob or Users = Rob
  • In a post function, I set the Assignee to unassigned but before I do that I first fill the 'Users' field using %%CURRENT_USER%% and setting the 'append' flag so that the 'Users' field is filled with the person that was working on the issue before the Assignee is set to unassigned.
  • What you see is that 'Rob' is indeed copied to the custom 'Users' field but when I use the filter on my task board to filter on 'Rob' it does not show the issue. It seems as if 'Rob' is not recognized.
  • If I edit this issue and only press 'Save' then the issue is seen when I filter on 'Rob'. So it seems that 'Save' does something with the 'Users' field.

 

Any idea how to fix this?

5 answers

This widget could not be displayed.

Rob, What post function do you use. JIRA doesn't contain such post function, but there are some plugins that allow to do it.

This widget could not be displayed.

Hi Robert,

The post function is the following.

The value %%CURRENT_USER%% will be appended to field Users, or set if it is a multi field.

See screenshots

Post_Function.png

Detailed.

Post_Function_Detailed.png

This widget could not be displayed.

Id you're using Update Custom Field Value post function please use %%ADD_CURRENT_USER%%

instead of %%CURRENT_USER%%

Please check if your Users field is multi user or single user type

This widget could not be displayed.

I tried it and although the tool mentions that you should not use it (obsolete), it has exactly the same effect.

The current user is copied to the 'Users' field but is only recognized as user when after you edit the issue and press 'Save'.

I do not know the details of course but is seems that some kind of translation is needed to make 'Rob' to be seen as user. This happens at least when you press 'Save'.

 

Can you send screenshot from the custom field definition (administration->issues->custom fields ? And please also attach your workflow transition post function list.

This widget could not be displayed.

Hi Robert,

Apparently I can ask three questions a day after which I am blocked. Should I follow another path to continue with this?

Below two screenshots

Users_Custom_Field.png

 

Post_Function_List.png

Screenshot about not being able to answer (I edited this answer twice so it might be that I cannot repond anymore today).

No_Answer_Possible.png

You can comment if you can't answer :) I tried to replicate same issue in my JIRA 6.4.7 and JIRA Suite Utilities 1.4.10 and it works fine. Check your logs and attach error if it throws any

I think I also could not comment. I will see if I could get the logfile. Any specific logfile or error I should look for?

Hello Robert. Can you let me know which Logfiles I should investigate and where I can find them? Thanks.

Hi Robert. I got the logfiles but have no clue where to look for. Do you want me to update them?

Hi Robert. For your information. Atlassian support could also reproduce the problem. I am now contacting the supplier of the plug-in to see if they have a solution.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

593 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you