Build error in atlas-run command during the hello world tutorial

Hello,

I'm facing a build error during Step3.3 of the Hello World plugin on the https://developer.atlassian.com/display/DOCS/Create+a+HelloWorld+Plugin+Project.

I'm in behind firewall in my company, so I specified proxy setting in settings.xml and it seems downloading jar files are working fine.

Here is my build error.

C:\Src\sample\helloworld>atlas-run
Executing: "C:\SDK\atlassian-plugin-sdk-4.0\apache-maven\bin\mvn.bat" com.atlass
ian.maven.plugins:maven-amps-dispatcher-plugin:4.0:run
[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building helloworld
[INFO] task-segment: [com.atlassian.maven.plugins:maven-amps-dispatcher-plugi
n:4.0:run]
[INFO] ------------------------------------------------------------------------
[INFO] Preparing amps-dispatcher:run
[INFO] artifact com.atlassian.maven.plugins:maven-amps-plugin: checking for upda
tes from atlassian-public
[WARNING] repository metadata for: 'artifact com.atlassian.maven.plugins:maven-a
mps-plugin' could not be retrieved from repository: atlassian-public due to an e
rror: Error transferring file: m2proxy.atlassian.com
[INFO] Repository 'atlassian-public' will be blacklisted
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] The plugin 'com.atlassian.maven.plugins:maven-amps-plugin' does not exist
or no valid version could be found
[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 1 second
[INFO] Finished at: Tue Nov 20 19:43:44 JST 2012
[INFO] Final Memory: 10M/75M
[INFO] ------------------------------------------------------------------------

Could you please give me some advices? I'm new for the plugin development.

3 answers

0 votes
Yilin Mo Atlassian Team Nov 19, 2012

It looks like you've got some problem when connecting tot m2proxy.atlassian.com, can you check with your network admin on this :)

I have almost the same response and I don't have access to m2proxy.atlassian.com. Could this be the reason to fail? Here it is the log:

C:\atlastutorial\helloworld>atlas-run

Executing: "C:\Users\abalbiscalvino\atlassian-plugin-sdk-4.0\apache-maven\bin\mvn.bat" com.atlassian.maven.plugins:maven-amps-dispatcher-plugin:4.0:run

[INFO] Scanning for projects...

[INFO] ------------------------------------------------------------------------

[INFO] Building helloworld

[INFO]    task-segment: [com.atlassian.maven.plugins:maven-amps-dispatcher-plugin:4.0:run]

[INFO] ------------------------------------------------------------------------

[INFO] Preparing amps-dispatcher:run

[INFO] artifact com.atlassian.maven.plugins:maven-amps-plugin: checking for updates from atlassian-public

[WARNING] repository metadata for: 'artifact com.atlassian.maven.plugins:maven-amps-plugin' could not be retrieved from repository: atlassian-public due to an error: Error transferring file: sun.secur

ity.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

[INFO] Repository 'atlassian-public' will be blacklisted

[INFO] ------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO] ------------------------------------------------------------------------

[INFO] The plugin 'com.atlassian.maven.plugins:maven-amps-plugin' does not exist or no valid version could be found

[INFO] ------------------------------------------------------------------------

[INFO] For more information, run Maven with the -e switch

[INFO] ------------------------------------------------------------------------

[INFO] Total time: 2 seconds

[INFO] Finished at: Fri Dec 07 15:14:13 CET 2012

[INFO] Final Memory: 10M/74M

[INFO] ------------------------------------------------------------------------

C:\atlastutorial\helloworld>

Solved!

m2proxy.atlassian.com was behind a proxy. Once I had access the problem dissapeared.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,223 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you