Broken Workflow - Is this a known issue?

I found a issue while working on Workflows. I observed the same issue on JIRA 4.4.5 and JIRA 5.2.5

Steps to Reproduce on JIRA 4.4.5..

1. Workflows -> Choose any workflow and click 'Create Draft' workflow
2. Choose any transition and Select 'Validators' -> 'Add' Validator
3. Select 'Fields Required' and click 'Add'
4. Without selecting any field from the available fields, click 'Add' button at the bottom of the screen
5. System Error

1 answer

0 votes

Well, um,

1. This isn't a core validator, it's probably the one from the Jira Suite Utilities. Check the versions of your plugins

2. The whole point of this validator is to check fields. So why are you not selecting one? It's not a valid input (that's not an excuse for handling it badly, but it does mean that there's a workaround - enter valid data)

1. JSU version is 1.3.5 which is latest on JIRA 5.2.5.

2. I agree, work around is to enter valid data.. I clicked the add button accidentally and found this broken screen but that is not an ideal screen for wrong handlings :)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,089 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you