Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,363,760
Community Members
 
Community Events
168
Community Groups

Automation rule fires successfully but custom fields are not updated

Hi,

I want to create a simple rule that automates setting the custom field of issues inside an epic as soon as the same value is changed in an epic. It's really extremely simple. My problem is, that I can see in the logs that the rule was executed successfully, I can also see the correct issue IDs that should have been affected by the execution. But when I check the issues the custom field is unchanged. Can anyone help here? 

Thanks & BR,

Christian

 

 

rule not firing.png

2 answers

1 accepted

2 votes
Answer accepted
Alex Koxaras Community Leader Sep 16, 2022

Hi @chg 

FIrst of all:

  • What do you place as an edit value on the Edit Issue (hub) within the branch?
  • Log the value of the above in the audit log.

Most likely the value is null, therefore no change.

Hi @Alex Koxaras 

thanks for the reply! It logged this: 

log.png

As far as I understand this, this looks fine (at least toString is not null...)

Alex Koxaras Community Leader Sep 16, 2022

What do you place in the Edit Issue component?

Is the Hub field visible on the Epic's stories?

"What do you place in the Edit Issue component?

--sorry, I don't understand the question

 

"Is the Hub field visible on the Epic's stories?"

-- Yes, that's how I found out that something is wrong. The values of the field on stroy level did not change.

Alex Koxaras Community Leader Sep 16, 2022

After the branch rule, you have place an Edit Issue action (rule component). Within this component you have selected to edit the Hub field. I need to know what value you place inside that field. Did you select the choice "copy value from trigger issue", or something else?

@Alex Koxaras You pointed me in the direction, now it works. I did not copy the value from the trigger issue but the current issue. Which, obviously, will not work. Thanks!

Like Alex Koxaras likes this
Alex Koxaras Community Leader Sep 16, 2022

Good to know that it worked out!

0 votes
Dave Mathijs Community Leader Sep 16, 2022

Hi @chg , welcome to the Atlassian Community!

Please check the audit log. Even if the rule is successful, the action might be skipped because the condition isn't met.

Hi @Dave Mathijs ,

thanks for the reply. I checked the audit log, that's why I am confused. It says the following:

 

success.png

 

it also states the correct ID of the issue that triggered the rule by changing the field and the correct IDs of all issues withing the epic. Looks totally fine to me.

Dave Mathijs Community Leader Sep 16, 2022

You don't have 2 custom fields named Hub by any chance?

I thought about this too. The custom field was named "Team" before (and the automation did not work), but since there are other fields with that name, I thought that this is maybe the issue. So I re-named the field to "Hub", but it didn't help.

Dave Mathijs Community Leader Sep 16, 2022

Was the field "Team" actually a custom field? Because Jira uses a couple of Team fields, for Tempo, for Advanced Roadmaps. It's best not to change the name of custom fields created by apps.

Do you have a screenshot of that custom field and type?

Hi @Dave Mathijs ,

I know about the "untouchable" fields, I really only updated the custom field I created.

Does the screenshot provide enough information?

hub.png

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events