Automation: Email not sent as part of automation Edited

Hi,

I am starting to use Jira Automation, and as part of a project, I want to be able to send emails as part of the automation.

Unfortunately, whenever I try and send an email with automation, the email goes to the mail queue, but then the email then goes to the error queue and I can't see a way to find the error log.

Also, when I put in the email address in the "To" field, the loading symbol (spinning annulus) is always there, no matter how long I leave it.

However, when I send a test email, that goes through just fine.

Thanks

3 answers

1 accepted

Figured out what was wrong with the help of Nick. In the "more options" for the email automation, there is a "From" field, which was prefilled out with an email that the email server would not accecpt, so I just had to change this to the default JIRA email address and it worked.

0 votes

Hi Ryan,

If you're using the Automation feature that is included in Jira Service Desk, that option to send email won't actually allow you to enter an explicit email address there (like user@example.com).

Instead this automation rule is only able to send emails to the reporter of the issue and/or requested participants on the issue.   There is an open feature request to change this functionality to allow other explicit email addresses here in https://jira.atlassian.com/browse/JSDSERVER-4309

It's strange that when you try to enter this email address in, the browser session should be validating against this and provide a warning that this is not expected to work.  However, it sounds like in your instance, if you continue to see a spinning icon when doing this that Jira might be stuck trying to validate the value you enter there.

In my instance when I click this window to set the To field, my browser prompts me to select one of these implicit roles instead of an explicit email address.

tofield1.png

I hope this helps,

Regards,
Andy

Hi Andy,

Thanks for the reply. Apologies, I should have specified, but I am actually using "Automoation for Jira" https://marketplace.atlassian.com/plugins/com.codebarrel.addons.automation/cloud/overview

And I just realised that it's developed by Code Barrel, so it may have been the wrong place to ask this.

Either way, in case anyone knows, I have also tried with assignees from the drop down to assignee and reporter, but that hasn't worked either. I'll talk to Code Barrell and see if they know.

Thanks again.

Oh sorry.  I've added the tags for that plugin and the marketplace tag to this post.

Much appreciated.

0 votes
Nick Menere Community Champion Nov 30, 2017

Hi Ryan,

I've just responded to your support request. This looks like there maybe some issue that is best diagnosed with logs and other info that you would most probably prefer not be public.

After we resolve the issue, I will come back post an update here.

Cheers,

Nick

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,968 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot