Attempting JIRA Integration with Existing Apache2 (pre 2.4) Installation, Documentation Unclear

Hey guys,

Sorry if this is rehashed, but my following of the documentation leads to a 503 Service Not Available code in Apache. The logs are also unhelpful because everything seems to be a-ok from JIRA's POV. So. Have an existing apache2 setup, has a few locations on the default site.

Could I get (or pointed to) a step by step on how to create a new location in apache to point to https://host/JIRA created for a brand new JIRA installation? I want to use HTTPS exclusively to access JIRA.

My current server.xml looks like this:

<Connector port="8080"
                   maxThreads="150"
                   minSpareThreads="25"
                   connectionTimeout="20000"
                   enableLookups="false"
                   maxHttpHeaderSize="8192"
                   protocol="HTTP/1.1"
                   useBodyEncodingForURI="true"
                   redirectPort="443"
                   acceptCount="100"
                   disableUploadTimeout="true"/>
        <Connector port="8080"
                   maxThreads="150"
                   minSpareThreads="25"
                   connectionTimeout="20000"
                   enableLookups="false"
                   maxHttpHeaderSize="8192"
                   protocol="HTTP/1.1"
                   useBodyEncodingForURI="true"
                   redirectPort="8443"
                   acceptCount="100"
                   disableUploadTimeout="true"
                   proxyName="hostnamehere"
                   proxyPort="80"
        />
 <Connector
                port="8443"
                protocol="org.apache.coyote.http11.Http11Protocol"
                maxHttpHeaderSize="8192"
                SSLEnabled="true"
                maxThreads="150"
                minSpareThreads="25"
                enableLookups="false"
                disableUploadTimeout="true"
                acceptCount="100"
                scheme="https"
                secure="true"
                clientAuth="false"
                sslProtocol="TLS"
                useBodyEncodingForURI="true"
        />
        <Connector
                port="8443"
                protocol="org.apache.coyote.http11.Http11Protocol"
                maxHttpHeaderSize="8192"
                SSLEnabled="true"
                maxThreads="150"
                minSpareThreads="25"
                enableLookups="false"
                disableUploadTimeout="true"
                acceptCount="100"
                scheme="https"
                secure="true"
                clientAuth="false"
                sslProtocol="TLS"
                useBodyEncodingForURI="true"
                proxyName="hostnamehere"
                proxyPort="443"
        />

<Engine name="Catalina" defaultHost="localhost">
            <Host name="localhost" appBase="webapps" unpackWARs="true" autoDeploy="true">
                <Context path="" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">

                    <!--
                     ====================================================================================
                     Note, you no longer configure your database driver or connection parameters here.
                     These are configured through the UI during application setup.
                     ====================================================================================
                    -->
                    <Resource name="UserTransaction" auth="Container" type="javax.transaction.UserTransaction"
                              factory="org.objectweb.jotm.UserTransactionFactory" jotm.timeout="60"/>
                    <Manager pathname=""/>
                </Context>
            </Host>

and I've done the following to the default site of my apache config:

# JIRA
        <Proxy *>
                Order deny,allow
                Allow from all
        </Proxy>
        <Location />
                Order deny,allow
                Allow from all
        </Location>
        SSLProxyEngine          On
        ProxyRequests           Off
        ProxyPreserveHost       Off
        ProxyPass               /       http://localhost:8443/
        ProxyPassReverse        /       http://localhost:8443/

There's probably a whole bunch of things wrong with this, but I'm way too inexperienced with JIRA to know what's going on, also pretty green with apache, any help would be greatly appreciated.

Thanks in advance.

1 answer

1 accepted

1 vote

It's the proxy settings - you're telling Apache to connect to JIRA on 8443 which is NOT the port for http!  Not sure where you got that from - the docs do say to connect to the http port.

Try changing it to 8080 in the Apache proxy settings.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

98 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you