It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Atlassian SDK and JIRA required JDK mismatch

This question is in reference to Atlassian Developer Documentation: Run your plugin in the container

 

atlas-run --product jira --version 6.1

JIRA 6.1 requires Java 1.7 while the newest Atlassian SDK can be run only under JDK 1.8

When I try to execute this command under JDK 1.8, initializing JIRA will fail due to exception:

java.lang.IllegalStateException: Cannot create ConcurrentHashMap - neither JDK 1.5 nor backport-concurrent available on the classpath

On the other hand, under JDK 1.7 the Atlassian SDK will rise an error.

How can I get around that problem?

 

Kind Regards,

Piotr

2 answers

1 vote
willy Atlassian Team Nov 22, 2016

You can run an older version of JIRA with the latest Atlassian SDK version installed and Java 1.7 by specifying an older maven-plugin-version (AMPS):

atlas-run-standalone --product jira --version 6.1 --maven-plugin-version 6.1.2 --data-version 6.1

This works since the Maven AMPS plugin version 6.1.2 has been compiled with an older version of Java.

The options are available for atlas-run as well (see "atlas-run --help").

See https://marketplace.atlassian.com/plugins/atlassian-plugin-sdk-windows/versions for versions and compatibility.

0 votes
Daniel Wester Community Leader Nov 05, 2016

The Atlassian sdk is using maven so if you set JAVA_HOME it should work. That said - JIRA 6.1 is eol:d...

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you