Atlassian JIRA service won't start after update

I updated from 7.0.1 to 7.4.2

Below are the files I made changes in previous version:- 
atlassian-jira\WEB-INF\web.xml
jre\lib\security\cacerts
conf\server.xml
conf\web.xml

 

Issues: 
1. I have added cacert in config.bat  and JIRA does not restart. it gives me error : " The Atlassian JIRA service on local computer started and then stopped. Some services stop automatically if they are not in use by other services or progrems". 

2. How can I get the JIRA url I was using before "jira.test.abs.gov" since I have added it in base url but its is still not accessible. I can run local host url on local only before I add cacert.

let me know if need other clarifications to understand this sceanrio.

Thanks 
Amit.

2 answers

0 vote

>I have added cacert in config.bat

What does that mean, and why have you done it?  CA Certificates need to be added to the certificate store.   Why are you even looking at batch files?

To reuse a url, make sure your DNS points to the server and then change the base url.

Thanks for qquick response. 

I had ca cert info for this instance already like keystore path , password etc. so I added that in config.bat> webserver tab instead of adding in server.xml. ( just want to add it on updated version instance)

anyways this is second part, first I need it running on local and act normal. 

I googled how to set up jira dns /server but didnt help much. if you know how can I do it?

Certificates don't go into server.xml either.  I'm really struggling to understand what you're doing, or why?

Go to https://confluence.atlassian.com/adminjiraserver071/running-jira-applications-over-ssl-or-https-802593051.html and scroll down to

Configure your web server using the JIRA config tool

I'm follwing this to add webserver settings.

--------------

I'm just trying to update jira from 7.0.1 to 7.4.2 which I did. 

but issues I need to fix are below.

1. I lost the url I was using but now its on http://localhost/secure that has to go back to the url I was using. 

2. It would run on https://jira.test.ab******.gov (for example)

There's nothing there telling you to put stuff in config.bat or putting certificates into server.xml, so I'm still lost.

Don't worry about the urls,  you need to get the service running first.  Can you put server.xml and config.bat back the way they were installed and run it again to see if we can at least get it started.

Yes I just did roll back all the changes and its working on the local. 

Now we need to fix url. and then I can add https part. 

Ok, great. 

So, you should be able to add the certificate to the cacerts file with the keytool command.  It won't make anything change on its own, the cacerts file really is just a list of certificate authorities that the system could use if it needs one.

To enable SSL and use it, you will then edit server.xml to point at the cacerts file (Again, that just makes it available, it does not trigger anything), and then the last step is to change server.xml to enable it.

So, assuming that works (can you log in on https://localhost:8443 ?) you can move on to the naming. 

That will need you to get your address owned and DNS set up so it points to your server, then you'll be able to connect to it remotely.

I didn't make any changes and today I see magic, the url is running without setting up DNS pointing to server. (I dont know how it happened) But I can run the custom url on local and remotly).

The only thing I need to do is to add ca cert info. which I did and restarted but it doesnt start the service.

here is the log error:  Its failing to initialize connector. 

1. 2-Aug-2017 09:54:28.527 SEVERE [main] org.apache.catalina.core.ContainerBase.startInternal A child container failed during start
java.util.concurrent.ExecutionException: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost]]

a lot more...............

I dont know where am I making mistake. 

I do not know what you are doing here.  Your DNS must have changed to allow the url to be found, and you don't explain "add ca cert info" or what the base error is.

The error in logs was " Http11Protocol". I changed it to "Http11NioProtocol" in server.xml 

 

It is working OK now. 

For the other light-weight Jira admins out there, like myself, it would be good to note that the config tool used to update operational parameters still uses the old protocol. So using it to restore your keystore information which got wiped out in the upgrade, it writes out a second Connect line with the old protocol.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

Mission-critical battery manufacturer fulfills FAA software requirements with Commit Policy Plugin

EaglePicher Technologies is a leading manufacturer of battery systems for diverse industries like defense, aviation, space or medical. As they operate in highly regulated industries, keeping a clear ...

165 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you