Application link issue

Hello All

We have JIRA and Fisheye/Crucible both on HTTPS

Initially we configured App link Between them with the OAuth authentication method and it worked successfully but now it is giving error 500.

OAuth option in Application Link wizard not visible for JIRA for both Incoming and Outgoing Authentication.

It is available in Fisheye/Crucible for Incoming Authentication but for Outgoing Authentication it is throwing bellow error.

An Application Link from the remote application to this application is required to configure this authentication provider.


Application Link 'JIRA' was created successfully locally but the reciprocal link was not created.


In JIRA on view issue page under review and source tab following error was thrown

javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

 

Is it related to SSL certificate??

 

can anybody explore how to configure SSL with

JIRA - Fisheye/Crucible

both application have same JAVA version.[1.7]

2 answers

I have been fighting this issue myself recently. You need to add the Fisheye key to the keystore on the JIRA server and the JIRA key to the keystore on the Fisheye server.

See this for more information.

https://confluence.atlassian.com/display/DOC/Running+Confluence+Over+SSL+or+HTTPS

Hi Jon, Thanks for quick reply. So I should create two keys each for jira and fisheye and exchange each other keystore. Will it work?

keystore.kst from both applications

Yes, use a key from the same key pair used to set up SSL, not a new key pair. Reboot both applications and rebuild the application links. It should work.

Hi, I am not able to find where to store this these keys. Should I do it Manually?

this is very urgent

0 vote
Brian Cruz Atlassian Team Mar 11, 2015

Hi Rahul,

 

This definitely points to an SSL error. We have a couple of KB Articles on resolving SSL errors. If you find that you're still unable to create the application link I'd recommend creating a support ticket to resolve the issue.

It seems like this may be related to SSLv3 "banning" that happen in Java 7u76.

 

I am experiencing the same error described in the original question trying to link to JIRA 6.3.15 front ended by apache from Confluence 5.7.4 running on Java 7u80.

http://mail.openjdk.java.net/pipermail/security-dev/2015-January/011667.html

Has anyone else run into this or know of an appropriate solution? I would prefer to continue using our reverse proxy with the SSL.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

741 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you