Agent gets no email notification when ticket gets assigned to him

Hi there,

we have a problem with our email notifications. If an agent gets assigned to a ticket, he recieves no email notification about that event.

Our notification settings seems to be right, but maybe I am missing something?

Unbenannt.PNGemail_notification_htim.PNG

3 answers

1 accepted

Okay I am not really sure what I have done, but the problem is solved now.

I played around with the user roles again. Set the ominous agent to the customer role again, added him to organizations and then set it all back.
All I have already done before (!) but now it worked.
So I think the main reason was a conflict between the agent account and adding the account to the role service desk customer or even a customer organization.

I am really confused but also glad the problem is solved now :)

Thanks a lot to @Alexey Matveevand @Ignacio Pulgar!

Ignacio Pulgar Community Champion Jan 09, 2018

Glad you could finally fix it! :)

Regards!

0 vote
Ignacio Pulgar Community Champion Jan 09, 2018

Did the user assigned the issue to himself, or was it assigned to him by anyone else?

If it was assigned by himself, that's the expected behaviour, provided that user 'does not get notified of its own changes'. That option can be changed from the user's profile.

The issue was assigned to him by someone else.

Ignacio Pulgar Community Champion Jan 09, 2018

Is the affected agent under the Service Desk Agents project role in the project the request belongs to? Note that Service Desk might override some of your configuration in the Notification Scheme.

May the affected agent double check the notification email has not been marked as spam, therefore skipping in the inbox?

0 vote
Alexey Matveev Community Champion Jan 09, 2018

Hello,

Accrording to your scheme current assignee will not get a notification when an issue was created. I mean if you create an issue and set an assignee for it then only support user wil be notified. Is it the case? Or even if you change the current assignee on an existing issue, the new assignee will not receive an email?

Yes, the support user is a composite user (agent) who recieves all tickets and also the email notifications after creating. This works without any problems.

Our support team proceeds the ticket and may assign it to another agent to work on it. And this step seems not to work properly.

Ignacio Pulgar Community Champion Jan 09, 2018

I think Alexey's point might be pointing to the solution here.

Just for clarifying it: Was the issue initially created and, afterwards, assigned to an Agent? Or was the issue assigned to the Agent from the Create Issue screen?

Alexey Matveev Community Champion Jan 09, 2018

Aslo you can troubleshoot your problems with the following article

https://confluence.atlassian.com/jirakb/mail-and-mail-handlers-troubleshooting-211649643.html

By creation the tickets get automatically assigned (via postfunctions in the workflow) to our support. This works without problems and the support user also gets the email notification.

I am a member of our support, so I see the email and assign the ticket to me (of course I get no notification) to communicate with the customer.

After I know the exact source of problem, I want to assign it to a corresponding agent (e.g. IT) who can handle this problem. But this agents recieves no email notification.

This would be our working progress. I hope the problem is clearer now.

Ignacio Pulgar Community Champion Jan 09, 2018

Thanks for the clarification.

May you confirm if the agent currently has an active Service Desk Agent license?

Yes, he does.

I tested the email notification with another agent just now. This agent does recieve an email.
So the problem seems to occur only by one agent!?

This is so strange :P

Alexey Matveev Community Champion Jan 09, 2018

Try to enable outgoing logs and have a look in the logs

Maybe another important hint is that this ominous agent had the service desk customer role in the project, too and he had recieved the customer notifications.

I expected a role conflict so I disabled the customer role again and deleted him from the organization as well. Still no success.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

Mission-critical battery manufacturer fulfills FAA software requirements with Commit Policy Plugin

EaglePicher Technologies is a leading manufacturer of battery systems for diverse industries like defense, aviation, space or medical. As they operate in highly regulated industries, keeping a clear ...

126 views 0 2
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you