After fresh JIRA install, JIRA returns a lot of 404s

I just did a fresh JIRA install of 5.0.3 on a Linux machine.

At some point, long in the past, this machine had a JIRA 4.1.1 instance on it. I dropped the old JIRA database in MySQL. I missed removing the "jira" user from /etc/passwd, so the 5.0.3 JIRA installer created a user named "jira1". Everything seemed to go smoothly, but when I tried to create my first project I got:

"Could not find servlet for: /plugins/servlet/project-config/PROJ/summary"

I also got an error from the main page claiming that "The Gadget Dashboard bundled plugin is not available."

So, I tried a "sudo service jira1 stop" followed by a "sudo service jira1 start"... This didn't improve the situation. Now I get:

The following plugins are required by JIRA, but have not been started:

  • Atlassian JIRA - Plugins - Project Config Plugin (com.atlassian.jira.jira-project-config-plugin)
  • Embedded Gadgets Plugin (com.atlassian.gadgets.embedded)
  • Gadget Dashboard Plugin (com.atlassian.gadgets.dashboard)
  • Gadget Spec Publisher Plugin (com.atlassian.gadgets.publisher)
  • Opensocial Plugin (com.atlassian.gadgets.opensocial)
  • Gadget Directory Plugin (com.atlassian.gadgets.directory)
  • Atlassian JIRA - Plugins - Gadgets Plugin (com.atlassian.jira.gadgets)

Hrm... What's gone horribly wrong here?

3 answers

I tried another stop/start, this time doing a "tail -f catalina.out". I waiting unit I go to the point where all the "Plugin Unit" lines were done, and I got to:

2012-05-01 00:03:13,976 Spring executor 4 INFO [jira.plugins.monitor.MonitoringScheduler] Scheduling metrics collector to run every 10000ms...

Then nothing exciting seemed to be happening, so I tried to go to my JIRA server in a web browser. Then, exiting things started to happen. :P

2012-05-01 00:03:58,053 Timer-0 WARN [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] Timeout occurred before finding service dependencies for [NonValidatingOsgiBundleXmlApplicationContext(bundle=com.atlassian.applinks.plugin, config=osgibundle:/META-INF/spring/*.xml)]
2012-05-01 00:03:58,105 Timer-0 ERROR [internal.dependencies.startup.DependencyWaiterApplicationContextExecutor] Unable to create application context for [com.atlassian.applinks.plugin], unsatisfied dependencies: Dependency on [(objectClass=com.atlassian.plugins.rest.common.util.RestUrlBuilder)] (from bean [&restUrlBuilder]), Dependency on [(objectClass=com.atlassian.sal.api.net.RequestFactory)] (from bean [&requestFactory]), Dependency on [(objectClass=com.atlassian.plugins.rest.common.json.JaxbJsonMarshaller)] (from bean [&jaxbJsonMarshaller])

This is followed by tons and tons of timout errors for various systems.

I have "top" running in another window - I'm not running out of memory, in fact I'm not even touching my swap yet. During this mass of timeouts, java is humming along at 93% CPU usage.

Although, this time I only get a list of 6 plugins in the "JIRA locked" screen instead of 7. Progress of a sort, I suppose.

I ran the "uninstall" in /opt/atlassian/jira, then I "rm -rf"ed /opt/atlassian and /var/atlassian". I removed my old "jira" user from /etc/passwd and /etc/shadow and /etc/group. I did a completely fresh install of JIRA.

I set up my database connection, and then got as far as the screen where I need to enter a license. I copy-pasted my old license, not realizing my server-ID had changed. It never got as far as telling me my license was bad, though; it died with a:

org.springframework.osgi.service.importer.ServiceProxyDestroyedException: service proxy has been destroyed

Looking at the logs, I again see all kinds of timeouts:

org.springframework.context.ApplicationContextException: Application context initialization for 'com.atlassian.applinks.plugin' has timed out

0 vote

Hi Jason,

Please check the following information.

  • Ensure all the plugins from JIRA 4 is compatible with JIRA 5.
  • Delete file on $JIRA_HOME/plugins/
    • .osgi plugins folder.
    • .bundled plugins folder.
  • Restart your linux services.

Hope it helps.

John

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

475 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you