It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

After an upgrade to Jira 6.2.3 (Jira Agile 6.3.12) agile gadgets are no longer available on the dashboard


We recently upgraded Jira and Jira Agile. After the upgrade, Jira agile gadgets on the dashboard are no longer available. The following warning can be found in the logs:

/secure/Dashboard.jspa [gadgets.renderer.internal.GadgetSpecFactoryImpl] Error occurred while retrieving gadget spec for rest/gadgets/1.0/g/com.pyxis.greenhopper.jira:greenhopper-gadget-sprint-burndown/gadgets/greenhopper-sprint-burndown.xml

The following is seen in the UI:

Error loading gadget from rest/gadgets/1.0/g/com.pyxis.greenhopper.jira:greenhopper-gadget-project-dashboard/gadgets/greenhopper-project-dashboard.xml: org.apache.shindig.gadgets.GadgetException: Unable to retrieve gadget xml. HTTP error 404

System as been re-indexed and restarted.

I have raised an issue with Atlassian support - but I'm trying out here as well.

2 answers

1 accepted

1 vote
Answer accepted
Pedro Souza Atlassian Team Apr 24, 2014

Hello Ivar,

I believe you are facing the problem described on this bug:

Below you can see the same SQL query from one of our test instances affected by the same issue. Note that we have one extra line, which is exactly the one mentioned in the Bug above:

After test the suggested workaround in the bug, everything seems to be working here, but I strongly suggest you to create a test instance for that, since we will modify the database directly. Also, database modifications need to be done with JIRA down, so a test instance will be easier for that, right?

Basically, you need to run the following queries in your JIRA database:

INSERT INTO propertyentry 
VALUES      ((SELECT seq_id 
              FROM   sequence_value_item 
              WHERE  seq_name = 'OSPropertyEntry'), 
INSERT INTO propertynumber 
VALUES      ((SELECT seq_id 
               FROM   sequence_value_item 
               WHERE  seq_name = 'OSPropertyEntry'), 

UPDATE sequence_value_item 
SET    seq_id = (SELECT seq_id 
               FROM   sequence_value_item 
               WHERE  seq_name = 'OSPropertyEntry') 
			                 + 10 
WHERE  seq_name = 'OSPropertyEntry';

I hope it helps.


Pedro Souza.

Thank you @Pedro; I got this information from the first Hercules report (before the restart of the server and cleaning the logs) as well. However, I disregarded it due to this comment: "If this returns more than 5k records you may be affected by this bug".

We have 212 fixVersions, not > 5K.

The bug is also reported for 6.0?

We tried on the test-db now. Agile gadgets appeared afterwards. Preparing prod installation now.

Problem solved.

1 vote

What versions did you upgrade from?

Also, does the log contain more details? Just after the first one you've got there?

@Nic, we upgraded from 5.2.11.

There is very little in the logs - Hercules had no suggestions. A lot of warnings related to the same gadget and other Jira Agile gadgets.

There is one error:

[sal.core.lifecycle.DefaultLifecycleManager] Unable to start component: $Proxy530

Suggest an answer

Log in or Sign up to answer

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you