Accessing https Jira via port 443


let me re-phrase my issue i posted last night.

Last night I tried to access jira using default ports i.e. 80 and 443 (by amending the server.xml port numbers) then accessing it through http://localhost:80 and https:localhost:443. But I received apache 404 error page. However, if i used any other random port it worked yesterday.

Today morning i uninstalled jira and did afresh installation and it worked. jira could then be accessed through all ports inc 80 and 443.

This now confirms that it was nothing to do with firewalls.

Any idea what may have been the root cause of the issue?

PS: I have a standalone installation on windows server.


3 answers

1 accepted

2 votes
Accepted answer

I would take a look at either this guide or

this guide

When you say apache 404 page do you mean the apache tomcat or are you running an apache httpd in front of jira? If you are running httpd, then you need to add your mod_proxy or mod_jk setting to the ssl vhost config in the httpd-ssl.conf file.


yes i meant 404 page apache is a standalone installation...if i use 8443 it works but not with 443....

can you post your server.xml file so we can see what might be the issue.

Hi Jason

It seems i have managed to resolve it. I uninstalled the jira and performed a fresh installation, patched the old server.xml. It then started accepting the default ports i.e. 80 and 443.

i.e. http://localhost and https://localhost started working.

But I am still unclear on why the webserver did not respond to 80 and 443 yesterday although it was responding to all other random ports. Any idea>


I think that the defaut connector config in the server.xml was taking over.

<Connector port="8080" disableUploadTimeout="true" acceptCount="100" redirectPort="8443" useBodyEncodingForURI="true" protocol="HTTP/1.1"
maxHttpHeaderSize="8192" enableLookups="false" connectionTimeout="20000" minSpareThreads="25" maxThreads="150"/>

You said it was working on port 8443 which is defined in the default connector as redirectPort. The Tomcat manual says this about the redirectPort:

"If this Connector is supporting non-SSL requests, and a request is received for which a matching <security-constraint> requires SSL transport, Catalina will automatically redirect the request to the port number specified here." link

It would seem that tomcat was picking up 8443 as the ssl port, not 443. I would guess that you could change the redirectPort to 443, configure the ssl options, and it would work. 8443 is the defualt value from the Tomcat project because, ports under 1024 on unix must be run under a root user.

When I uninstalled the Jira and re-installed it started accepting the port 443. I am still not sure what caused the problem. But anyways, thanks everyone for your responses earlier.


Also, I think that post in the low range below 1024 are restricted, hence You need to run jira as root (not as jira) to use them, see this old link:

But he said he was running this on Windows, which doesn't have the sub-1024 block in place.

Hi Rahul, please make sure that you have configured proxy settings (if you are behind one). And check too if some other service is using the same port.

is server.xml the only place to change if i have to change the ports?


You can use the Jira Configuration Tool too but I think it's the same thing (much cleaner). Check it here:

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,161 views 5 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you