64-bit installer hangs on Windows 7

The 64-bit installer (I tried 5.2.4, 5.2.4.1, 5.2.5 and 5.2) consistently hangs on Windows 7 Professional. It gets as far as the Express or Custom install form; if you choose Express, and click Next, it hangs immediately. It appears to be running another version of the installer with command line arguments; this version can't be killed, or even debugged (it complains about the loader lock).

So, is the 64-bit version actually installable?

3 answers

This widget could not be displayed.
Ivan Tse Atlassian Team Feb 02, 2013

I haven't had issue with it before. Have you tried to run the istaller as administrator? Can you install other software sucessfully? If you can't use the installer and really need run the software you can always install using the zip method.

I have tried the following:

1. Installing as administrator

2. Installing with AV disabled

3. Installing with -q (not sure if that's a silent install, but what the heck...)

along with rebooting to get rid of the hung installer processes, just in case they interact

I have installed other software on this machine, but possibly none using I4J.

This widget could not be displayed.

One last attempt.

  • Is there a JAVA_HOME variable in User/System environment variables? If yes remove it
  • Is there java.exe in PATH variable (User/System). Is yes remove that too.
  • Restart the system

Attempt the installation again as Administrator.

  • JAVA_HOME is not defined as an environment variable
  • java.exe is not in the path
  • As noted above, the system has been restarted several times

As noted above, the installation has already been attempted as Administrator

There's also this (bottom of i4j_nlog_43):


vmoption 6: -Dexe4j.consoleCodepage=cp0
vmoption 7: -Dinstall4j.executionMode=gui
vmoption 8: -Dsun.java2d.noddraw=true
vmoption 9: -Djava.class.path=C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\i4jruntime.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\platform.zip;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\commons-codec.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\commons-httpclient.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\commons-io.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\dom4j.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\inception.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\modzdetector.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\slf4j-api.jar;C:\Users\<me>\AppData\Local\Temp\e4j2FA5.tmp_dir\user\slf4j-jdk14.jar;
Creating JVM
JVM created
main class: com/install4j/runtime/launcher/WinLauncher
GetTempPath returned 34 (last error 0)
make dir returned -1
GetTempPath returned 34 (last error 183)
make dir returned -1
param count: 13
param 0: false
param 1: com.install4j.runtime.installer.Installer
param 2: C:\Users\<me>\Downloads\error.log
param 3:
param 4: false
param 5: C:\Users\<me>\Downloads\atlassian-jira-5.2.5-x64.exe
param 6: __i4j_lang_restart
param 7: -Duser.language=en
param 8: -Dinstall4j.language=en
param 9: -Dexe4j.unextractedPositionRestart=23888166
param 10: -Dinstall4j.commIdentifier=\\.\pipe\i4jcomm0
param 11: -Dexe4j.semaphoreName=c:_users_<me>_downloads_atlassian-jira-5.2.5-x64.exe
param 12: -Dinstall4j.restartResponseFile=C:\Users\<me>\AppData\Local\Temp\I4D008~1.VAR
calling main

The last 4 items in the install log follow.

[INFO] com.install4j.runtime.beans.actions.control.RunScriptAction [ID 70143]: Execute action
Property rollbackSupported: false
Property script: I4jScript_Internal_448
Property rollbackScript: null
Execute action successful
[INFO] com.install4j.runtime.beans.actions.control.SetVariableAction [ID 68901]: Execute action
Property variableName: sys.installationDir
Property rollbackSupported: false
Property script: I4jScript_Internal_450
Property onlyIfUndefined: false
Property failIfNull: false
Property responseFileVariable: false
Variable changed: sys.installationDir=C:\Program Files\Atlassian\JIRA[class java.lang.String]
Execute action successful
[INFO] com.install4j.runtime.beans.actions.control.SetVariableAction [ID 68902]: Execute action
Property variableName: app.defaultJiraHome
Property rollbackSupported: false
Property script: I4jScript_Internal_452
Property onlyIfUndefined: false
Property failIfNull: false
Property responseFileVariable: false
Variable changed: app.defaultJiraHome=C:\Program Files\Atlassian\Application Data\JIRA[class java.lang.String]
Execute action successful
[INFO] com.install4j.runtime.beans.actions.control.RunScriptAction [ID 69783]: Execute action
Property rollbackSupported: false
Property script: I4jScript_Internal_456
Property rollbackScript: null
Variable changed: app.jiraHome=C:\Program Files\Atlassian\Application Data\JIRA[class java.lang.String]
Variable changed: httpPort=8080[class java.lang.Long]
Variable changed: rmiPort=8005[class java.lang.Long]
Variable changed: app.install.service=true[class java.lang.Boolean]
<eof>


This widget could not be displayed.

The restartResponseFile above contained a reference to C:\Program Files\JIRA . I manually created that directory, rebooted, ran the installer again as administrator, and it worked. (Actually, the installer hung again at "Launching JIRA", but I was able to complete the rest of the install from my browser.)

Note that C:\Program Files\JIRA is not the install directory for JIRA (it's empty).

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

576 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you